summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorIlya Verbin <ilya.verbin@intel.com>2014-10-19 19:40:59 +0000
committerIlya Verbin <iverbin@gcc.gnu.org>2014-10-19 19:40:59 +0000
commitd856054bc7b4d494010234816bcb25e837eea3b1 (patch)
treeb1a71a512384885501a7bb4ae73a119c424e9965 /gcc/configure.ac
parente80f9fef341bdd66fff59e18df3044f5fe2e5166 (diff)
downloadgcc-d856054bc7b4d494010234816bcb25e837eea3b1.tar.gz
Set SECTION_EXCLUDE flag for LTO sections.
gcc/ * configure: Regenerate. * configure.ac: Move the test for section attribute specifier "e" in GAS out to all i[34567]86-*-* | x86_64-*-* targets and add --fatal-warnings. * langhooks.c (lhd_begin_section): Set SECTION_EXCLUDE flag. * varasm.c (default_elf_asm_named_section): Guard SECTION_EXCLUDE with ifdef HAVE_GAS_SECTION_EXCLUDE. From-SVN: r216442
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 8f7c814b483..35ce9eeb45a 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -3799,18 +3799,19 @@ foo: nop
;;
esac
fi
- # Test if the assembler supports the section flag 'e' for specifying
- # an excluded section.
- gcc_GAS_CHECK_FEATURE([.section with e], gcc_cv_as_section_has_e,
- [2,22,51],,
-[.section foo1,"e"
-.byte 0,0,0,0])
- AC_DEFINE_UNQUOTED(HAVE_GAS_SECTION_EXCLUDE,
- [`if test $gcc_cv_as_section_has_e = yes; then echo 1; else echo 0; fi`],
- [Define if your assembler supports specifying the section flag e.])
;;
esac
+ # Test if the assembler supports the section flag 'e' for specifying
+ # an excluded section.
+ gcc_GAS_CHECK_FEATURE([.section with e], gcc_cv_as_section_has_e,
+ [2,22,51], [--fatal-warnings],
+[.section foo1,"e"
+.byte 0,0,0,0])
+ AC_DEFINE_UNQUOTED(HAVE_GAS_SECTION_EXCLUDE,
+ [`if test $gcc_cv_as_section_has_e = yes; then echo 1; else echo 0; fi`],
+ [Define if your assembler supports specifying the section flag e.])
+
gcc_GAS_CHECK_FEATURE([filds and fists mnemonics],
gcc_cv_as_ix86_filds,,,
[filds mem; fists mem],,