summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authoroliva <oliva@138bc75d-0d04-0410-961f-82ee72b054a4>1999-09-18 18:25:50 +0000
committeroliva <oliva@138bc75d-0d04-0410-961f-82ee72b054a4>1999-09-18 18:25:50 +0000
commit006523dc4793702f35c330af3b9095593c316b0e (patch)
treefe153b55e6c51890aa614613e9383010070b42c9 /gcc/configure.in
parent57c097d5fd1d34d642722293f1fe09870c38839c (diff)
downloadgcc-006523dc4793702f35c330af3b9095593c316b0e.tar.gz
* configure.in: Pick up thread library on Solaris/x86 just
like on Solaris/sparc. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@29501 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 1ae1a9ad27e..51687e82ba6 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -1548,8 +1548,18 @@ changequote([,])dnl
tmake_file=i386/t-sol2
extra_parts="crt1.o crti.o crtn.o gcrt1.o gmon.o crtbegin.o crtend.o"
xmake_file=x-svr4
- if test x$enable_threads = xyes; then
+ if test x${enable_threads} = x; then
+ enable_threads=$have_pthread_h
+ if test x${enable_threads} = x; then
+ enable_threads=$have_thread_h
+ fi
+ fi
+ if test x${enable_threads} = xyes; then
+ if test x${have_pthread_h} = xyes; then
+ thread_file='posix'
+ else
thread_file='solaris'
+ fi
fi
;;
changequote(,)dnl