summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>1999-09-22 14:23:22 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>1999-09-22 14:23:22 +0000
commit11e01324589a2b6e90ecfe0759cfaaa153c9ca11 (patch)
tree18937a41ec03788e260cae33ca8f438ac7b21fd2 /gcc/configure.in
parent5404a0e7afcfe580c31f55a2d0e05a6f571e0564 (diff)
downloadgcc-11e01324589a2b6e90ecfe0759cfaaa153c9ca11.tar.gz
* configure.in (AC_PREREQ): Bump to 2.13.
(AC_C_STRINGIZE): Call this instead of using a custom macro. * gansidecl.h (HAVE_STRINGIZE): Define, if stage2 gcc && __STDC__. * system.h (HAVE_STRINGIZE): Test this instead of HAVE_CPP_STRINGIFY. * acconfig.h (HAVE_CPP_STRINGIFY): Delete. * alpha/xm-vms.h (HAVE_CPP_STRINGIFY): Delete. (HAVE_STRINGIZE): Define. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@29590 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in17
1 files changed, 4 insertions, 13 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 5db57ae10cb..c89f95f2d0c 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -21,7 +21,7 @@
#Boston, MA 02111-1307, USA.
# Initialization and defaults
-AC_PREREQ(2.12.1)
+AC_PREREQ(2.13)
AC_INIT(tree.c)
AC_CONFIG_HEADER(auto-host.h:config.in)
@@ -346,18 +346,9 @@ AC_CHECK_HEADER(pthread.h, [have_pthread_h=yes], [have_pthread_h=])
# See if GNAT has been installed
AC_CHECK_PROG(gnat, gnatbind, yes, no)
-# See if the system preprocessor understands the ANSI C preprocessor
-# stringification operator.
-AC_MSG_CHECKING(whether cpp understands the stringify operator)
-AC_CACHE_VAL(gcc_cv_c_have_stringify,
-[AC_TRY_COMPILE(,
-[#define S(x) #x
-char *test = S(foo);],
-gcc_cv_c_have_stringify=yes, gcc_cv_c_have_stringify=no)])
-AC_MSG_RESULT($gcc_cv_c_have_stringify)
-if test $gcc_cv_c_have_stringify = yes; then
- AC_DEFINE(HAVE_CPP_STRINGIFY)
-fi
+# See if the stage1 system preprocessor understands the ANSI C
+# preprocessor stringification operator.
+AC_C_STRINGIZE
# Use <inttypes.h> only if it exists,
# doesn't clash with <sys/types.h>, and declares intmax_t.