summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorPascal Obry <obry@act-europe.fr>2001-06-06 00:00:22 +0200
committerDJ Delorie <dj@gcc.gnu.org>2001-06-05 18:00:22 -0400
commit9dd53f2c1b3ca1aac698c864422ac8d0d2c42d84 (patch)
tree411c1f73b735bc19cf7f3cf410e7c47c0055bf8c /gcc/configure.in
parentd558416ef32eb82c6cf3b8fa446709690567c777 (diff)
downloadgcc-9dd53f2c1b3ca1aac698c864422ac8d0d2c42d84.tar.gz
configure.in: Quote $enable_win32_registry in case the value has spaces in it.
* configure.in: Quote $enable_win32_registry in case the value has spaces in it. * configure: Ditto. From-SVN: r42920
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 9924517f076..0c9117ad98a 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -939,7 +939,7 @@ AC_ARG_ENABLE(win32-registry,
case $host_os in
win32 | pe | cygwin* | mingw32* | uwin*)
AC_MSG_CHECKING(whether windows registry support is requested)
-if test x$enable_win32_registry != xno; then
+if test "x$enable_win32_registry" != xno; then
AC_DEFINE(ENABLE_WIN32_REGISTRY, 1,
[Define to 1 if installation paths should be looked up in Windows32
Registry. Ignored on non windows32 hosts.])
@@ -950,7 +950,7 @@ else
fi
# Check if user specified a different registry key.
-case x${enable_win32_registry} in
+case "x${enable_win32_registry}" in
x | xyes)
# default.
gcc_cv_win32_registry_key="$VERSION"
@@ -965,7 +965,7 @@ xno)
;;
esac
-if test x$enable_win32_registry != xno; then
+if test "x$enable_win32_registry" != xno; then
AC_MSG_CHECKING(registry key on windows hosts)
AC_DEFINE_UNQUOTED(WIN32_REGISTRY_KEY, "$gcc_cv_win32_registry_key",
[Define to be the last portion of registry key on windows hosts.])