summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorEric Christopher <echristo@gcc.gnu.org>2003-09-10 00:13:11 +0000
committerEric Christopher <echristo@gcc.gnu.org>2003-09-10 00:13:11 +0000
commitbace148a4965470f6093f81746e564f54f014ced (patch)
tree3c7864407399d922fccafbc6eacf77e8350d4c31 /gcc/configure.in
parentdd07abd7259e11e6e7a9e6e91d100e9c8743273a (diff)
downloadgcc-bace148a4965470f6093f81746e564f54f014ced.tar.gz
configure.in: Change usage of 'head' to 'sed 1q'.
2003-09-09 Eric Christopher <echristo@redhat.com> * configure.in: Change usage of 'head' to 'sed 1q'. * configure: Regenerate. From-SVN: r71255
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index b0926a77644..20a2c35eea0 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -1820,7 +1820,7 @@ AC_CACHE_CHECK(linker for .hidden support, gcc_cv_ld_hidden,
fi
else
gcc_cv_ld_hidden=yes
- ld_ver=`$gcc_cv_ld --version 2>/dev/null | head -1`
+ ld_ver=`$gcc_cv_ld --version 2>/dev/null | sed 1q`
if echo "$ld_ver" | grep GNU > /dev/null; then
changequote(,)dnl
ld_vers=`echo $ld_ver | sed -n \
@@ -1882,7 +1882,7 @@ L2:],
# ??? There exists an elf-specific test that will crash
# the assembler. Perhaps it's better to figure out whether
# arbitrary sections are supported and try the test.
- as_ver=`$gcc_cv_as --version 2>/dev/null | head -1`
+ as_ver=`$gcc_cv_as --version 2>/dev/null | sed 1q`
if echo "$as_ver" | grep GNU > /dev/null; then
changequote(,)dnl
as_ver=`echo $as_ver | sed -e 's/GNU assembler \([0-9.][0-9.]*\).*/\1/'`