summaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@suse.de>2003-10-03 17:49:39 +0000
committerAndreas Schwab <schwab@gcc.gnu.org>2003-10-03 17:49:39 +0000
commitc6c51600ab4c16f62ab1f4abc518cd84e3a4fed9 (patch)
tree0f2cf3449bd82e413bc1c533ccd677730737326f /gcc/configure.in
parent290f6157c842ac3db2267d0ef95a735adb83f9d4 (diff)
downloadgcc-c6c51600ab4c16f62ab1f4abc518cd84e3a4fed9.tar.gz
re PR bootstrap/12276 (Configure check for libunwind does not work with cross)
PR bootstrap/12276 * configure.in: Check for libunwind on the host only if building a native compiler. * configure: Regenerated. From-SVN: r72072
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 6f03111cb1d..855cd0bc943 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -941,7 +941,11 @@ AC_ARG_ENABLE(sjlj-exceptions,
AC_DEFINE_UNQUOTED(CONFIG_SJLJ_EXCEPTIONS, $sjlj,
[Define 0/1 to force the choice for exception handling model.])])
-AC_CHECK_LIB(unwind, main, use_libunwind_default=yes, use_libunwind_default=no)
+if test x$host = x$target; then
+ AC_CHECK_LIB(unwind, main, use_libunwind_default=yes, use_libunwind_default=no)
+else
+ use_libunwind_default=no
+fi
# Use libunwind based exception handling.
AC_ARG_ENABLE(libunwind-exceptions,
[ --enable-libunwind-exceptions force use libunwind for exceptions],