summaryrefslogtreecommitdiff
path: root/intl/configure.ac
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2017-11-07 15:24:01 +1030
committerAlan Modra <amodra@gcc.gnu.org>2017-11-07 15:24:01 +1030
commit2d041117f1ee47982a2d8a2a9801f2906df2d91f (patch)
tree2ca2957253ad56dc167fa1e15aea016de8595408 /intl/configure.ac
parent0ed1b4890a9cc4be7e24416a37eb14638f5adf7e (diff)
downloadgcc-2d041117f1ee47982a2d8a2a9801f2906df2d91f.tar.gz
Require ngettext in test of system gettext implementation
gcc currently uses ngettext in a number of places (gcc/cp/pt.c, gcc/diagnostic.c, gcc/collect2.c). Apparently there are (or used to be) gettext implementations that lack ngettext. See config/gettext.m4. This patch arranges for intl/ to be compiled when the system gettext lacks ngettext. * configure.ac: Invoke AM_GNU_GETTEXT with need_ngettext. * configure: Regenerate. From-SVN: r254486
Diffstat (limited to 'intl/configure.ac')
-rw-r--r--intl/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/intl/configure.ac b/intl/configure.ac
index 698c330ddb3..36cf97fe4b1 100644
--- a/intl/configure.ac
+++ b/intl/configure.ac
@@ -4,7 +4,7 @@ AC_CONFIG_SRCDIR(gettext.c)
AC_CONFIG_HEADER(config.h)
AC_CONFIG_MACRO_DIR(../config)
AM_GNU_GETTEXT_VERSION(0.12.1)
-AM_GNU_GETTEXT
+AM_GNU_GETTEXT([], [need-ngettext])
# This replaces the extensive use of DEFS in the original Makefile.in.
AC_DEFINE(IN_LIBINTL, 1, [Define because this is libintl.])