summaryrefslogtreecommitdiff
path: root/libbacktrace/Makefile.am
diff options
context:
space:
mode:
authorTom de Vries <tdevries@suse.de>2019-01-28 22:21:19 +0000
committerTom de Vries <vries@gcc.gnu.org>2019-01-28 22:21:19 +0000
commit62d4a355b7346242fd2242a41662f3b18340f53d (patch)
tree1857f30aa773cb56b54368657b754eef669986a4 /libbacktrace/Makefile.am
parentb6d0f41ac5c1786911858b4763bb6f92519166f4 (diff)
downloadgcc-62d4a355b7346242fd2242a41662f3b18340f53d.tar.gz
[libbacktrace] Fix and simplify xcoff_%.c pattern rule
When generating xcoff_%.c, the last command is a sed command. In case of a sed failure, this will leave an incomplete file, which will appear as up to date to make, so consequently it will not be regenerated. Fix this by sedding into a temporary file instead. Also, use $< to access the prerequisite xcoff.c, instead of spelling out the file name once more. 2019-01-28 Tom de Vries <tdevries@suse.de> * Makefile.am (xcoff_%.c): Generate sed result into temporary file. Use $< to access prerequisite. * Makefile.in: Regenerate. From-SVN: r268344
Diffstat (limited to 'libbacktrace/Makefile.am')
-rw-r--r--libbacktrace/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/libbacktrace/Makefile.am b/libbacktrace/Makefile.am
index 997a535dff4..0d5b3193e25 100644
--- a/libbacktrace/Makefile.am
+++ b/libbacktrace/Makefile.am
@@ -108,8 +108,9 @@ xcoff_%.c: xcoff.c
REPLACE='#undef BACKTRACE_XCOFF_SIZE\
#define BACKTRACE_XCOFF_SIZE'; \
$(SED) "s/^$$SEARCH\$$/$$REPLACE $*/" \
- $(srcdir)/xcoff.c \
- > $@
+ $< \
+ > $@.tmp
+ mv $@.tmp $@
test_elf_SOURCES = test_format.c testlib.c
test_elf_LDADD = libbacktrace_noformat.la elf.lo