summaryrefslogtreecommitdiff
path: root/libbacktrace/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <iant@golang.org>2021-01-18 14:45:57 -0800
committerIan Lance Taylor <iant@golang.org>2021-01-18 14:45:57 -0800
commitbfde774667fbce6d7d326c8a36a098138e224a95 (patch)
tree223c3b15e82af241d8e51b489165d8c21d849525 /libbacktrace/Makefile.am
parent325e70b47c6c321710c7b9c792b8fbee95cecd63 (diff)
downloadgcc-bfde774667fbce6d7d326c8a36a098138e224a95.tar.gz
libbacktrace: don't fail tests if dwz fails
* Makefile.am (%_dwz): If dwz fails, use uncompressed debug info. * Makefile.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'libbacktrace/Makefile.am')
-rw-r--r--libbacktrace/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/libbacktrace/Makefile.am b/libbacktrace/Makefile.am
index e1e55009f09..8874f41338a 100644
--- a/libbacktrace/Makefile.am
+++ b/libbacktrace/Makefile.am
@@ -303,9 +303,13 @@ if HAVE_DWZ
rm -f $@ $@_common.debug
cp $< $@_1
cp $< $@_2
- $(DWZ) -m $@_common.debug $@_1 $@_2
- rm -f $@_2
- mv $@_1 $@
+ if $(DWZ) -m $@_common.debug $@_1 $@_2; then \
+ rm -f $@_2; \
+ mv $@_1 $@; \
+ else \
+ echo "Ignoring dwz errors, assuming that test passes"; \
+ cp $< $@; \
+ fi
TESTS += btest_dwz