summaryrefslogtreecommitdiff
path: root/libcc1/Makefile.am
diff options
context:
space:
mode:
authorSergio Durigan Junior <sergiodj@redhat.com>2017-11-16 18:15:33 +0000
committerJeff Law <law@gcc.gnu.org>2017-11-16 11:15:33 -0700
commit9d99775c34864d030d97b6a5ea5987616ff37468 (patch)
tree2de8be5e2648fec8c4e0080f09145cb6a267409c /libcc1/Makefile.am
parentdc03239c2d8607a0f5cdb13a220bcf0c7f8ed7cd (diff)
downloadgcc-9d99775c34864d030d97b6a5ea5987616ff37468.tar.gz
Makefile.am: Remove references to c-compiler-name.h and cp-compiler-name.h
* Makefile.am: Remove references to c-compiler-name.h and cp-compiler-name.h * Makefile.in: Regenerate. * compiler-name.hh: New file. * libcc1.cc: Don't include c-compiler-name.h. Include compiler-name.hh. * libcp1.cc: Don't include cp-compiler-name.h. Include compiler-name.hh. Co-Authored-By: Pedro Alves <palves@redhat.com> From-SVN: r254838
Diffstat (limited to 'libcc1/Makefile.am')
-rw-r--r--libcc1/Makefile.am18
1 files changed, 0 insertions, 18 deletions
diff --git a/libcc1/Makefile.am b/libcc1/Makefile.am
index 5e61a92a26b..cdba5a50b23 100644
--- a/libcc1/Makefile.am
+++ b/libcc1/Makefile.am
@@ -45,24 +45,6 @@ plugin_LTLIBRARIES = libcc1plugin.la libcp1plugin.la
cc1lib_LTLIBRARIES = libcc1.la
endif
-BUILT_SOURCES = c-compiler-name.h cp-compiler-name.h
-MOSTLYCLEANFILES = c-compiler-name.h cp-compiler-name.h
-
-# Put this in a header so we don't run sed for each compilation. This
-# is also simpler to debug as one can easily see the constant.
-# FIXME: compute it in configure.ac and output it in config.status, or
-# introduce timestamp files for some indirection to avoid rebuilding it
-# every time.
-c-compiler-name.h: Makefile
- -rm -f $@T
- echo "#define C_COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > $@T
- mv $@T $@ # $(SHELL) $(srcdir)/../move-if-change $@T $@
-
-cp-compiler-name.h: Makefile
- -rm -f $@T
- echo "#define CP_COMPILER_NAME \"`echo g++ | sed '$(transform)'`\"" > $@T
- mv $@T $@ # $(SHELL) $(srcdir)/../move-if-change $@T $@
-
shared_source = callbacks.cc callbacks.hh connection.cc connection.hh \
marshall.cc marshall.hh rpc.hh status.hh