summaryrefslogtreecommitdiff
path: root/libcc1/Makefile.am
diff options
context:
space:
mode:
authorSegher Boessenkool <segher@kernel.crashing.org>2016-04-11 09:26:36 +0200
committerSegher Boessenkool <segher@gcc.gnu.org>2016-04-11 09:26:36 +0200
commitfa246aa37ad88aeb6f12b93e67a4bd1516a084d6 (patch)
treeacd9cb5711ff45e2f26cfc66ae79b4dccc4327c4 /libcc1/Makefile.am
parent890e48b46084daa41d53a7d49fb02f5037c15dbd (diff)
downloadgcc-fa246aa37ad88aeb6f12b93e67a4bd1516a084d6.tar.gz
libcc1: Clean compiler-name.h (PR70173)
Since the file is generated from a Makefile fragment, it needs to be added to MOSTLYCLEANFILES. The directory itself is still not deleted (just like the gnattools and gotools directories). 2016-04-11 Segher Boessenkool <segher@kernel.crashing.org> libcc1/ PR bootstrap/70173 * Makefile.am (MOSTLYCLEANFILES): New, add compiler-name.h . (compiler-name.h): Shorten recipe so that it fits the line. * Makefile.in: Regenerate. From-SVN: r234874
Diffstat (limited to 'libcc1/Makefile.am')
-rw-r--r--libcc1/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libcc1/Makefile.am b/libcc1/Makefile.am
index 7a274b3470c..b40820b2189 100644
--- a/libcc1/Makefile.am
+++ b/libcc1/Makefile.am
@@ -44,11 +44,12 @@ cc1lib_LTLIBRARIES = libcc1.la
endif
BUILT_SOURCES = compiler-name.h
+MOSTLYCLEANFILES = compiler-name.h
# Put this in a header so we don't run sed for each compilation. This
# is also simpler to debug as one can easily see the constant.
compiler-name.h: Makefile
- echo "#define COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > compiler-name.h
+ echo "#define COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > $@
shared_source = callbacks.cc callbacks.hh connection.cc connection.hh \