summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-04-07 17:09:10 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-04-07 17:09:10 +0000
commit35a02ae0037490ed40c3b0a2be08112d38414d33 (patch)
tree39c2c0da7b6c220dd344f134fae07fba0d0266b2 /libgo/Makefile.am
parentf14e9371b41a0c54075d54c5867df13b63474191 (diff)
downloadgcc-35a02ae0037490ed40c3b0a2be08112d38414d33.tar.gz
libgo: Update to current Go library.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@172106 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am48
1 files changed, 23 insertions, 25 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index c40456f62f6..3c943310182 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -177,10 +177,10 @@ toolexeclibgocryptodir = $(toolexeclibgodir)/crypto
toolexeclibgocrypto_DATA = \
crypto/aes.gox \
- crypto/block.gox \
crypto/blowfish.gox \
crypto/cast5.gox \
crypto/cipher.gox \
+ crypto/des.gox \
crypto/dsa.gox \
crypto/ecdsa.gox \
crypto/elliptic.gox \
@@ -727,9 +727,12 @@ go_os_files = \
go/os/env.go \
go/os/env_unix.go \
go/os/error.go \
+ go/os/error_posix.go \
go/os/exec.go \
+ go/os/exec_posix.go \
go/os/exec_unix.go \
go/os/file.go \
+ go/os/file_posix.go \
go/os/file_unix.go \
go/os/getwd.go \
go/os/path.go \
@@ -932,16 +935,6 @@ go_crypto_aes_files = \
go/crypto/aes/block.go \
go/crypto/aes/cipher.go \
go/crypto/aes/const.go
-go_crypto_block_files = \
- go/crypto/block/cbc.go \
- go/crypto/block/cfb.go \
- go/crypto/block/cmac.go \
- go/crypto/block/cipher.go \
- go/crypto/block/ctr.go \
- go/crypto/block/eax.go \
- go/crypto/block/ecb.go \
- go/crypto/block/ofb.go \
- go/crypto/block/xor.go
go_crypto_blowfish_files = \
go/crypto/blowfish/block.go \
go/crypto/blowfish/const.go \
@@ -956,6 +949,10 @@ go_crypto_cipher_files = \
go/crypto/cipher/io.go \
go/crypto/cipher/ocfb.go \
go/crypto/cipher/ofb.go
+go_crypto_des_files = \
+ go/crypto/des/block.go \
+ go/crypto/des/cipher.go \
+ go/crypto/des/const.go
go_crypto_dsa_files = \
go/crypto/dsa/dsa.go
go_crypto_ecdsa_files = \
@@ -1428,10 +1425,10 @@ libgo_go_objs = \
container/ring.lo \
container/vector.lo \
crypto/aes.lo \
- crypto/block.lo \
crypto/blowfish.lo \
crypto/cast5.lo \
crypto/cipher.lo \
+ crypto/des.lo \
crypto/dsa.lo \
crypto/ecdsa.lo \
crypto/elliptic.lo \
@@ -2026,13 +2023,6 @@ crypto/aes/check: $(CHECK_DEPS)
@$(CHECK)
.PHONY: crypto/aes/check
-crypto/block.lo: $(go_crypto_block_files) fmt.gox io.gox os.gox strconv.gox
- $(BUILDPACKAGE)
-crypto/block/check: $(CHECK_DEPS)
- @$(MKDIR_P) crypto/block
- @$(CHECK)
-.PHONY: crypto/block/check
-
crypto/blowfish.lo: $(go_crypto_blowfish_files) os.gox strconv.gox
$(BUILDPACKAGE)
crypto/blowfish/check: $(CHECK_DEPS)
@@ -2054,6 +2044,13 @@ crypto/cipher/check: $(CHECK_DEPS)
@$(CHECK)
.PHONY: crypto/cipher/check
+crypto/des.lo: $(go_crypto_des_files) encoding/binary.gox os.gox strconv.gox
+ $(BUILDPACKAGE)
+crypto/des/check: $(CHECK_DEPS)
+ @$(MKDIR_P) crypto/des
+ @$(CHECK)
+.PHONY: crypto/des/check
+
crypto/dsa.lo: $(go_crypto_dsa_files) big.gox io.gox os.gox
$(BUILDPACKAGE)
crypto/dsa/check: $(CHECK_DEPS)
@@ -2139,7 +2136,8 @@ crypto/ripemd160/check: $(CHECK_DEPS)
.PHONY: crypto/ripemd160/check
crypto/rsa.lo: $(go_crypto_rsa_files) big.gox crypto.gox crypto/sha1.gox \
- crypto/subtle.gox encoding/hex.gox hash.gox io.gox os.gox
+ crypto/subtle.gox encoding/hex.gox hash.gox io.gox os.gox \
+ sync.gox
$(BUILDPACKAGE)
crypto/rsa/check: $(CHECK_DEPS)
@$(MKDIR_P) crypto/rsa
@@ -2475,8 +2473,8 @@ http/cgi/check: $(CHECK_DEPS)
@$(CHECK)
.PHONY: http/cgi/check
-http/httptest.lo: $(go_http_httptest_files) bytes.gox fmt.gox http.gox \
- net.gox os.gox
+http/httptest.lo: $(go_http_httptest_files) bytes.gox crypto/rand.gox \
+ crypto/tls.gox fmt.gox http.gox net.gox os.gox time.gox
$(BUILDPACKAGE)
http/httptest/check: $(CHECK_DEPS)
@$(MKDIR_P) http/httptest
@@ -2767,14 +2765,14 @@ container/vector.gox: container/vector.lo
crypto/aes.gox: crypto/aes.lo
$(BUILDGOX)
-crypto/block.gox: crypto/block.lo
- $(BUILDGOX)
crypto/blowfish.gox: crypto/blowfish.lo
$(BUILDGOX)
crypto/cast5.gox: crypto/cast5.lo
$(BUILDGOX)
crypto/cipher.gox: crypto/cipher.lo
$(BUILDGOX)
+crypto/des.gox: crypto/des.lo
+ $(BUILDGOX)
crypto/dsa.gox: crypto/dsa.lo
$(BUILDGOX)
crypto/ecdsa.gox: crypto/ecdsa.lo
@@ -3002,10 +3000,10 @@ TEST_PACKAGES = \
container/ring/check \
container/vector/check \
crypto/aes/check \
- crypto/block/check \
crypto/blowfish/check \
crypto/cast5/check \
crypto/cipher/check \
+ crypto/des/check \
crypto/dsa/check \
crypto/ecdsa/check \
crypto/elliptic/check \