summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-30 22:34:55 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2011-03-30 22:34:55 +0000
commitccd3f476fe018616f62e4d79fe2d202ad58611f7 (patch)
treead346d0e1a6a29f4ca3ea6a450e50c5896ed8047 /libgo/Makefile.am
parentb5f807a8f37e07a04343d57c8e51a4663e944121 (diff)
downloadgcc-ccd3f476fe018616f62e4d79fe2d202ad58611f7.tar.gz
libgo: Support systems which do not have strerror_r.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@171757 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index 0a13bc96188..476d4aaf3a2 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -1264,7 +1264,11 @@ endif
if LIBGO_IS_RTEMS
syscall_errstr_file = syscalls/errstr_rtems.go
else
+if HAVE_STRERROR_R
syscall_errstr_file = syscalls/errstr.go
+else
+syscall_errstr_file = syscalls/errstr_nor.go
+endif
endif
# Declare libc_strerror_r which is the Go name for strerror_r.
@@ -1273,7 +1277,7 @@ if LIBGO_IS_RTEMS
syscall_errstr_decl_file = syscalls/errstr_decl_rtems.go
else
if LIBGO_IS_LINUX
-# In Linux the POSIX strerror_r is called __xpg_strerror_r.
+# On GNU/Linux the POSIX strerror_r is called __xpg_strerror_r.
syscall_errstr_decl_file = syscalls/errstr_decl_linux.go
else
# On other systems we hope strerror_r is just strerror_r.