summaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2014-05-29 20:22:27 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2014-05-29 20:22:27 +0000
commit7920387d2737f27c68a9e2f81ea298a2bf596070 (patch)
treeffb905fbae8b421551bac556d96607de00cb5918 /libgo/configure.ac
parentdcd5393fd5b3ac53775a5546f3103958b64789bb (diff)
downloadgcc-7920387d2737f27c68a9e2f81ea298a2bf596070.tar.gz
runtime: add the --without-libatomic configure option
This adds the --without-libatomic configure option, which is useful for building libgo with a non-gcc compiler. It disables libgo's dependency on libatomic. This is useful for platforms where it is known that the libatomic runtime functions are not required, or where the compiler automatically provides an implementation of them. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@211065 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index 8f55cac797c..1f5aea8c676 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -122,6 +122,21 @@ fi
AC_SUBST(LIBFFI)
AC_SUBST(LIBFFIINCS)
+# See if the user wants to configure without libatomic. This is useful if we are
+# on an architecture for which libgo does not need an atomic support library and
+# libatomic does not support our C compiler.
+AC_ARG_WITH(libatomic,
+ AS_HELP_STRING([--without-libatomic],
+ [don't use libatomic]),
+ [:],
+ [with_libatomic=${with_libatomic_default-yes}])
+
+LIBATOMIC=
+if test "$with_libatomic" != no; then
+ LIBATOMIC=../libatomic/libatomic_convenience.la
+fi
+AC_SUBST(LIBATOMIC)
+
# Used to tell GNU make to include a file without telling automake to
# include it.
go_include="-include"