summaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authoraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2002-05-08 04:38:00 +0000
committeraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2002-05-08 04:38:00 +0000
commit0b045cf7e3079e720da52fe4b56c1111c5c9f126 (patch)
treefda34a055cd15f68de4616295d6d596d3e47e2c1 /libiberty/configure.in
parentb1157638a7839a075313f66e37944aad2aedafc7 (diff)
downloadgcc-0b045cf7e3079e720da52fe4b56c1111c5c9f126.tar.gz
* configure.in (ORIGINAL_LD_FOR_MULTILIBS): Preserve LD at
script entry, and set LD to it when configuring multilibs. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@53278 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index f3ec32ae3c4..f6d92bcb03e 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -3,6 +3,12 @@ dnl Process this file with autoconf to produce a configure script
AC_PREREQ(2.13)
AC_INIT(pexecute.c)
+# This works around the fact that libtool configuration may change LD
+# for this particular configuration, but some shells, instead of
+# keeping the changes in LD private, export them just because LD is
+# exported. We don't use libtool yet, but some day we might, so...
+ORIGINAL_LD_FOR_MULTILIBS=$LD
+
dnl We use these options to decide which functions to include.
AC_ARG_WITH(target-subdir,
[ --with-target-subdir=SUBDIR Configuring in a subdirectory for target])
@@ -427,6 +433,7 @@ if test -n "$CONFIG_FILES"; then
if test -n "${with_build_subdir}" || test -n "${with_target_subdir}"; then
# FIXME: We shouldn't need to set ac_file
ac_file=Makefile
+ LD="${ORIGINAL_LD_FOR_MULTILIBS}"
. ${libiberty_topdir}/config-ml.in
fi
fi],