summaryrefslogtreecommitdiff
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2006-10-10 18:44:06 +0000
committerTom Tromey <tromey@gcc.gnu.org>2006-10-10 18:44:06 +0000
commit51d0a5cc301ae12e47e2152ad1152ecfaec23bad (patch)
treea03086e84b086b36577ffb106762873ea572df61 /libjava/Makefile.am
parent21825fd6200448af24f9b1b59ee6a42edd434a6a (diff)
downloadgcc-51d0a5cc301ae12e47e2152ad1152ecfaec23bad.tar.gz
re PR libgcj/29205 (lib/pkgconfig/libgcj.pc needs to become version dependent)
PR libgcj/29205: * Makefile.in: Rebuilt. * Makefile.am (install-data-local): Install the .pc file. (pkgconfig_DATA): Removed. From-SVN: r117610
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index 764cb96d894..f7ceccd5917 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -47,7 +47,6 @@ endif
dbexec_LTLIBRARIES = libjvm.la
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libgcj.pc
jardir = $(datadir)/java
jar_DATA = libgcj-$(gcc_version).jar libgcj-tools-$(gcc_version).jar
@@ -547,6 +546,11 @@ endif
## hand.
install-data-local:
$(PRE_INSTALL)
+## Install the .pc file.
+ @pc_version=`echo $(GCJVERSION) | sed -e 's/[.][^.]*$$//'`; \
+ file="libgcj-$${pc_version}.pc"; \
+ echo " $(INSTALL_DATA) libgcj.pc $(DESTDIR)$(pkgconfigdir)/$$file"; \
+ $(INSTALL_DATA) libgcj.pc $(DESTDIR)$(pkgconfigdir)/$$file
## We use a GNU make trick here so that we don't go over the command
## length limit of some shells.
@echo Creating list of headers to install...