summaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-29 18:46:34 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2007-01-29 18:46:34 +0000
commit8b6c1d2e8b7fdd171dfb9e65fe44685b2af698f6 (patch)
tree812c5f5af659cd3f7b8ac6c143e0c2b2efb55b14 /libjava/configure.ac
parent3d033e32a96ef8cf6b669d6d094ec36aef64e68d (diff)
downloadgcc-8b6c1d2e8b7fdd171dfb9e65fe44685b2af698f6.tar.gz
* configure, Makefile.in: Rebuilt.
* Makefile.am (bin_SCRIPTS): Never install scripts/jar. * configure.ac (BASH_JAR): Removed conditional. (JAR): Prefer the jar found by AC_CHECK_PROGS. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@121301 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index 773814d1d39..a62805c1fab 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -117,14 +117,14 @@ AC_PROG_AWK
AC_CHECK_PROGS([JAR], [jar fastjar gjar], no)
AC_PATH_PROG([ZIP], [zip], no)
AC_PATH_PROG([UNZIP], [unzip], unzip)
-AM_CONDITIONAL(BASH_JAR, test "$JAR" = no)
-if test "$ZIP" = no; then
- if test "$JAR" = no; then
+# Prefer the jar we found, but fall back to our jar script.
+if test "$JAR" = no; then
+ if test "$ZIP" = no; then
AC_MSG_ERROR([cannot find neither zip nor jar, cannot continue])
+ else
+ # InfoZIP available, use the 'guaranteed' Bourne-shell JAR to build libjava
+ JAR=`pwd`/scripts/jar
fi
-else
- # InfoZIP available, use the 'guaranteed' Bourne-shell JAR to build libjava
- JAR=`pwd`/scripts/jar
fi
AC_PROG_INSTALL