summaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authorbstarynk <bstarynk@138bc75d-0d04-0410-961f-82ee72b054a4>2011-02-22 15:46:28 +0000
committerbstarynk <bstarynk@138bc75d-0d04-0410-961f-82ee72b054a4>2011-02-22 15:46:28 +0000
commita73a02d4abe0f60de65430a0a424523328183dac (patch)
tree67e23990fe17046d32a863d25079fd4417959f45 /libjava/configure.ac
parent34038a3641143619b4c19bb31810a2e41c434714 (diff)
downloadgcc-a73a02d4abe0f60de65430a0a424523328183dac.tar.gz
2011-02-22 Basile Starynkevitch <basile@starynkevitch.net>
MELT branch merged with trunk rev 170399 using svnmerge git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/melt-branch@170403 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac19
1 files changed, 8 insertions, 11 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index a45cfc967d4..8187eecbd40 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -1843,21 +1843,18 @@ AC_SUBST(here)
# We get this from the environment.
AC_SUBST(GCJFLAGS)
+default_python_dir="/share/gcc-`cat ${srcdir}/../gcc/BASE-VER`/python/libjava"
AC_ARG_WITH([python-dir],
AS_HELP_STRING([--with-python-dir],
[the location to install Python modules. This path should NOT include the prefix.]),
- [with_python_dir=$withval], [with_python_dir=""])
+ [with_python_dir=$withval], [with_python_dir="${default_python_dir}"])
+
+# Needed for installing Python modules during make install.
+python_mod_dir="\${prefix}${with_python_dir}"
+
+# Needed for substituting into aot-compile*
+python_mod_dir_expanded="${expanded_prefix}${with_python_dir}"
-if test "x${with_python_dir}" = "x"
-then
- # Needed for installing Python modules during make install.
- python_mod_dir="\${prefix}/share/python"
- # Needed for substituting into aot-compile*
- python_mod_dir_expanded="${expanded_prefix}/share/python"
-else
- python_mod_dir="\${prefix}${with_python_dir}"
- python_mod_dir_expanded="${expanded_prefix}${with_python_dir}"
-fi
AC_MSG_RESULT(Python modules dir: ${python_mod_dir_expanded});
AC_SUBST(python_mod_dir)
AC_SUBST(python_mod_dir_expanded)