summaryrefslogtreecommitdiff
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2010-08-27 04:27:40 +0000
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2010-08-27 04:27:40 +0000
commitcda5fe864d366d244bbfb4da6d492cfc837dea7d (patch)
treef65631ede4a921c4935389a45f2258cc29d1a33d /libjava/configure.ac
parent2f1887bd485c2c34b5f1e5bc300db4b9afaf0e23 (diff)
downloadgcc-cda5fe864d366d244bbfb4da6d492cfc837dea7d.tar.gz
Fix building ecjx in cross compile mode.
libjava/: PR libgcj/40868 * configure.ac: Add GCC_FOR_ECJX variable. Ensure GCJ_FOR_ECJX is always set. * Makefile.am [!NATIVE] (ecjx.$(OBJEXT)): New rule. * Makefile.in: Regenerate. * configure: Regenerate. * gcj/Makefile.in: Regenerate. * include/Makefile.in: Regenerate. * testsuite/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@163580 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index 685cb725575..df6bca3f662 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -394,7 +394,8 @@ NATIVE=yes
# Which gcj and host gcj (for ecjx) do we use?
which_gcj=default
host_exeext=${ac_exeext}
-GCJ_FOR_ECJX=
+GCJ_FOR_ECJX='$(GCJ)'
+GCC_FOR_ECJX='$(CXX)'
built_gcc_dir="`cd ${builddotdot}/../../${host_subdir}/gcc && ${PWDCMD-pwd}`"
if test -n "${with_cross_host}"; then
# We are being configured with a cross compiler. We can't
@@ -402,6 +403,7 @@ if test -n "${with_cross_host}"; then
NATIVE=no
cross_host_exeext=
GCJ_FOR_ECJX="${with_cross_host}-gcj"
+ GCC_FOR_ECJX="${with_cross_host}-gcc"
case "${with_cross_host}" in
*mingw* | *cygwin*)
cross_host_exeext=.exe
@@ -467,6 +469,7 @@ JAVAC="$GCJ -C"
export JAVAC
AC_SUBST(GCJ_FOR_ECJX)
+AC_SUBST(GCC_FOR_ECJX)
AC_SUBST(GCJH)
AC_SUBST(host_exeext)