summaryrefslogtreecommitdiff
path: root/libobjc/configure.ac
diff options
context:
space:
mode:
authordavek <davek@138bc75d-0d04-0410-961f-82ee72b054a4>2010-03-23 05:05:35 +0000
committerdavek <davek@138bc75d-0d04-0410-961f-82ee72b054a4>2010-03-23 05:05:35 +0000
commit41f834440c6ccfa2a41c886f468c778aaa238d94 (patch)
tree001ab977795e25f5b8478f231054b6d12b5f139a /libobjc/configure.ac
parent201b2150310da54289444ef733cb3ef7f21b7b97 (diff)
downloadgcc-41f834440c6ccfa2a41c886f468c778aaa238d94.tar.gz
PR libobjc/30445
* configure.ac (extra_ldflags_libobjc): Define appropriately for Cygwin and MinGW hosts. * Makefile.am (libobjc_s.a): Remove dead pre-libtool target. (libobjc.dll): Likewise. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@157662 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libobjc/configure.ac')
-rw-r--r--libobjc/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/libobjc/configure.ac b/libobjc/configure.ac
index c2d860ff724..8820edc7e64 100644
--- a/libobjc/configure.ac
+++ b/libobjc/configure.ac
@@ -161,6 +161,10 @@ case "${host}" in
# Darwin needs -single_module when linking libobjc
extra_ldflags_libobjc=-Wl,-single_module
;;
+ *-cygwin*|*-mingw*)
+ # Tell libtool to build DLLs on Windows
+ extra_ldflags_libobjc='-no-undefined -bindir $(bindir)'
+ ;;
esac
AC_SUBST(extra_ldflags_libobjc)