summaryrefslogtreecommitdiff
path: root/libphobos/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2020-05-08 15:11:24 -0700
committerH.J. Lu <hjl.tools@gmail.com>2020-05-08 15:11:41 -0700
commit08c1d39d3a822dfe7d91524ec290e0f230504242 (patch)
treee3fcc961eb1d924b527d3cc41724e3ca2ae30a04 /libphobos/configure.ac
parent74dc179a6da33cd00f6d4a93fbb97dc84f610126 (diff)
downloadgcc-08c1d39d3a822dfe7d91524ec290e0f230504242.tar.gz
libphobos: Add --enable-cet to configure
When --enable-cet is used to configure GCC, enable Intel CET in libphobos. * Makefile.am (AM_MAKEFLAGS): Add $(CET_FLAGS) to GCC FLAGS. * configure.ac (CET_FLAGS): Add GCC_CET_FLAGS and AC_SUBST. * Makefile.in: Regenerated. * aclocal.m4: Likewise. * configure.ac: Likewise.
Diffstat (limited to 'libphobos/configure.ac')
-rw-r--r--libphobos/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/libphobos/configure.ac b/libphobos/configure.ac
index c21da5908d0..ec8a30ea511 100644
--- a/libphobos/configure.ac
+++ b/libphobos/configure.ac
@@ -65,6 +65,10 @@ AC_PROG_RANLIB
AC_PROG_INSTALL
AC_PROG_MAKE_SET
+# Add CET specific flags if CET is enabled
+GCC_CET_FLAGS(CET_FLAGS)
+AC_SUBST(CET_FLAGS)
+
# This should be inherited in the recursive make, but ensure it is defined.
test "$AR" || AR=ar
AC_SUBST(AR)