summaryrefslogtreecommitdiff
path: root/libphobos/configure.ac
diff options
context:
space:
mode:
authorIain Buclaw <ibuclaw@gdcproject.org>2019-04-12 06:25:17 +0000
committerIain Buclaw <ibuclaw@gcc.gnu.org>2019-04-12 06:25:17 +0000
commit0d6aae249d1a2ac9efe67407553711be3883a7f8 (patch)
tree1731fc388464c1b457df04fa9cbc13b96961a099 /libphobos/configure.ac
parentc50eadba265a0e9b3b84267477f953d0d5872522 (diff)
downloadgcc-0d6aae249d1a2ac9efe67407553711be3883a7f8.tar.gz
libphobos: Replace library check programs with dg-runtest
Fixes multilib handling when running the libphobos testsuite. libphobos/ChangeLog: 2019-04-12 Iain Buclaw <ibuclaw@gdcproject.org> PR d/89255 * configure.ac (ENABLE_SHARED, ENABLE_STATIC): Remove conditionals. * configure: Regenerate. * d_rules.am (%.t.lo, %.t.o): Remove rules. (unittest_static_LINK, unittest_LINK, libgdruntime_t_la_LINK, libgphobos_t_la_LINK): Remove variables. * libdruntime/Makefile.am (DRUNTIME_TEST_LOBJECTS, DRUNTIME_TEST_OBJECTS, check_PROGRAMS, check_LTLIBRARIES, unittest_static_SOURCES, unittest_static_LIBTOOLFLAGS, unittest_static_LDFLAGS, unittest_static_LDADD, EXTRA_unittest_static_DEPENDENCIES, libgdruntime_t_la_SOURCES, libgdruntime_t_la_LIBTOOLFLAGS, libgdruntime_t_la_LDFLAGS, libgdruntime_t_la_LIBADD, EXTRA_libgdruntime_t_la_DEPENDENCIES, unittest_SOURCES, unittest_LIBTOOLFLAGS, unittest_LDFLAGS, unittest_LDADD): Remove variables. (clean-local): Remove rule. * libdruntime/Makefile.in: Regenerate. * src/Makefile.am (PHOBOS_TEST_LOBJECTS, PHOBOS_TEST_OBJECTS, check_PROGRAMS, check_LTLIBRARIES, unittest_static_SOURCES, unittest_static_LIBTOOLFLAGS, unittest_static_LDFLAGS, unittest_static_LDADD, EXTRA_unittest_static_DEPENDENCIES, libgdruntime_t_la_SOURCES, libgdruntime_t_la_LIBTOOLFLAGS, libgdruntime_t_la_LDFLAGS, libgdruntime_t_la_LIBADD, EXTRA_libgdruntime_t_la_DEPENDENCIES, unittest_SOURCES, unittest_LIBTOOLFLAGS, unittest_LDFLAGS, unittest_LDADD): Remove variables. (clean-local): Remove rule. * src/Makefile.in: Regenerate. * testsuite/lib/libphobos.exp (libphobos_test_name): New global. (libphobos_init): Set libphobos_test_name. (libphobos-dg-test): Override name if libphobos_test_name is set. (filter_libphobos_unittests): New proc. * testsuite/libphobos.aa/aa.exp: Don't load libphobos-dg.exp. * testsuite/libphobos.cycles/cycles.exp: Set libphobos_test_name. * testsuite/libphobos.druntime/druntime.exp: New file. * testsuite/libphobos.druntime_shared/druntime_shared.exp: New file. * testsuite/libphobos.phobos/phobos.exp: New file. * testsuite/libphobos.phobos_shared/phobos_shared.exp: New file. * testsuite/libphobos.shared/shared.exp: Use dg-runtest to run tests. * testsuite/libphobos.hash/hash.exp: Don't load libphobos-dg.exp * testsuite/libphobos.init_fini/init_fini.exp: Likewise. * testsuite/libphobos.thread/thread.exp: Likewise. * testsuite/libphobos.typeinfo/typeinfo.exp: Likewise. * testsuite/libphobos.unittests/unittests.exp: Remove. * testsuite/test_runner.d: Remove. * testsuite/testsuite_flags.in: Add phobos to --gdcpaths. From-SVN: r270302
Diffstat (limited to 'libphobos/configure.ac')
-rw-r--r--libphobos/configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/libphobos/configure.ac b/libphobos/configure.ac
index 8cc735563cb..362f7537ffb 100644
--- a/libphobos/configure.ac
+++ b/libphobos/configure.ac
@@ -75,8 +75,6 @@ AC_SUBST(CFLAGS_FOR_BUILD)
LT_INIT(dlopen)
AM_PROG_LIBTOOL
WITH_LOCAL_DRUNTIME([LT_LANG([D])], [])
-AM_CONDITIONAL([ENABLE_SHARED], [test "$enable_shared" = "yes"])
-AM_CONDITIONAL([ENABLE_STATIC], [test "$enable_static" = "yes"])
# libtool variables for Phobos shared and position-independent compiles.
#