summaryrefslogtreecommitdiff
path: root/libquadmath/configure.ac
diff options
context:
space:
mode:
authorburnus <burnus@138bc75d-0d04-0410-961f-82ee72b054a4>2010-12-08 08:06:49 +0000
committerburnus <burnus@138bc75d-0d04-0410-961f-82ee72b054a4>2010-12-08 08:06:49 +0000
commitd658011316dbae0762a14f294c9395a3a33ac103 (patch)
tree2b1ed8c40ac9bc96e92cf0633b01f6ea4c4a5e23 /libquadmath/configure.ac
parent7d17fab3d03af64501d703bcb59f8870220c4ed1 (diff)
downloadgcc-d658011316dbae0762a14f294c9395a3a33ac103.tar.gz
2010-12-08 Tobias Burnus <burnus@net-b.de>
PR fortran/46543 * configure.ac: Add texinfo checks. * Makefile.am: Handle .texi documentation. * libquadmath.texi: New. * configure: Regenerated. * Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@167583 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libquadmath/configure.ac')
-rw-r--r--libquadmath/configure.ac31
1 files changed, 30 insertions, 1 deletions
diff --git a/libquadmath/configure.ac b/libquadmath/configure.ac
index 82ee93f7e56..a80d60b2221 100644
--- a/libquadmath/configure.ac
+++ b/libquadmath/configure.ac
@@ -30,7 +30,8 @@ AM_INIT_AUTOMAKE([1.9.0 foreign subdir-objects no-dist -Wall -Werror])
AC_MSG_CHECKING([for --enable-version-specific-runtime-libs])
AC_ARG_ENABLE(version-specific-runtime-libs,
-[ --enable-version-specific-runtime-libs Specify that runtime libraries should be installed in a compiler-specific directory ],
+AS_HELP_STRING([--enable-version-specific-runtime-libs],
+ [specify that runtime libraries should be installed in a compiler-specific directory]),
[case "$enableval" in
yes) version_specific_libs=yes ;;
no) version_specific_libs=no ;;
@@ -41,6 +42,14 @@ AC_MSG_RESULT($version_specific_libs)
GCC_NO_EXECUTABLES
+# See if makeinfo has been installed and is modern enough
+# that we can use it.
+ACX_CHECK_PROG_VER([MAKEINFO], [makeinfo], [--version],
+ [GNU texinfo.* \([0-9][0-9.]*\)],
+ [4.[4-9]*|4.[1-9][0-9]*|[5-9]*|[1-9][0-9]*])
+AM_CONDITIONAL(BUILD_INFO, test $gcc_cv_prog_makeinfo_modern = "yes")
+
+
# Configure libtool
AM_PROG_LIBTOOL
ACX_LT_HOST_FLAGS
@@ -187,5 +196,25 @@ else
multilib_arg=
fi
+
+# We would like our source tree to be readonly. However when releases or
+# pre-releases are generated, the flex/bison generated files as well as the
+# various formats of manuals need to be included along with the rest of the
+# sources. Therefore we have --enable-generated-files-in-srcdir to do
+# just that.
+AC_MSG_CHECKING(generated-files-in-srcdir)
+AC_ARG_ENABLE(generated-files-in-srcdir,
+AS_HELP_STRING([--enable-generated-files-in-srcdir],
+ [put copies of generated files in source dir intended for creating source tarballs for users without texinfo bison or flex]),
+[case "$enableval" in
+ yes) enable_generated_files_in_srcdir=yes ;;
+ no) enable_generated_files_in_srcdir=no ;;
+ *) AC_MSG_ERROR([Unknown argument to enable/disable version-specific libs]);;
+ esac],
+[enable_generated_files_in_srcdir=no])
+AC_MSG_RESULT($enable_generated_files_in_srcdir)
+AM_CONDITIONAL(GENINSRC, test "$enable_generated_files_in_srcdir" = yes)
+
+
AC_CONFIG_FILES(Makefile)
AC_OUTPUT