summaryrefslogtreecommitdiff
path: root/libstdc++-v3/configure.ac
diff options
context:
space:
mode:
authorpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 00:38:28 +0000
committerpme <pme@138bc75d-0d04-0410-961f-82ee72b054a4>2003-08-27 00:38:28 +0000
commit4591e20f03e57b651cf3dac127909f747b4a92c7 (patch)
treedd98bcfa8b7c51e66c2927eed518cb1f935b1dc0 /libstdc++-v3/configure.ac
parent7acd3d7d5190a8d527753e0c5727c9faec36a842 (diff)
downloadgcc-4591e20f03e57b651cf3dac127909f747b4a92c7.tar.gz
2003-08-26 Phil Edwards <pme@gcc.gnu.org>
* Makefile.am: Add comment. * acinclude.m4 (GLIBCXX_CONFIGURE): Set new glibcxx_SUBDIRS and SUBDIRS variables. * configure.ac: Use them both here, instead of hardcoded lists. * fragment.am: Add STAMP varaible. * include/Makefile.am: Cosmetic whitespace cleanup. Use $(LN_S) instead of @LN_S@. (stamp-*): Move file creation rule outside of 'if' branches to ensure the stamp-* files are actually updated. Use $(STAMP). * src/Makefile.am: Remove now-nonexistant variable. * libsupc++/Makefile.am: Likewise. Snap the assignment chain for -prefer-pic. * po/Makefile.am: Include same fragment as all the others. * aclocal.m4, configure, Makefile.in, include/Makefile.in, libsupc++/Makefile.in, po/Makefile.in, src/Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@70836 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/configure.ac')
-rw-r--r--libstdc++-v3/configure.ac17
1 files changed, 7 insertions, 10 deletions
diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac
index 50467e74c84..326b22f19e6 100644
--- a/libstdc++-v3/configure.ac
+++ b/libstdc++-v3/configure.ac
@@ -294,15 +294,10 @@ AC_SUBST(LIBSUPCXX_PICFLAGS)
dnl In autoconf 2.5x, AC_OUTPUT is replaced by four AC_CONFIG_* macros,
dnl which can all be called multiple times as needed, plus one (different)
dnl AC_OUPUT macro. This one lists the files to be created:
-AC_CONFIG_FILES([ \
+AC_CONFIG_FILES( \
Makefile \
- include/Makefile \
- libmath/Makefile \
- libsupc++/Makefile \
- po/Makefile \
- src/Makefile \
- testsuite/Makefile \
- ])
+ AC_FOREACH([DIR], glibcxx_SUBDIRS, [DIR/Makefile ])
+ )
AC_CONFIG_FILES([scripts/check_survey],[chmod +x scripts/check_survey])
AC_CONFIG_FILES([scripts/testsuite_flags],[chmod +x scripts/testsuite_flags])
@@ -320,7 +315,7 @@ AC_CONFIG_COMMANDS([default],
cat > vpsed << \_EOF
s!`test -f '$<' || echo '$(srcdir)/'`!!
_EOF
- for i in libmath libsupc++ src testsuite; do
+ for i in $SUBDIRS; do
case $CONFIG_FILES in
*${i}/Makefile*)
#echo "Adding MULTISUBDIR to $i/Makefile"
@@ -335,7 +330,9 @@ _EOF
(cd include && ${MAKE-make})
],
[
-# No init-vars needed so far which aren't already passed by autoconf.
+# Variables needed in config.status (file generation) which aren't already
+# passed by autoconf.
+SUBDIRS="$SUBDIRS"
])
dnl And this actually makes things happen: