summaryrefslogtreecommitdiff
path: root/libstdc++-v3/libsupc++/Makefile.am
diff options
context:
space:
mode:
authorPhil Edwards <pme@gcc.gnu.org>2003-08-27 00:38:28 +0000
committerPhil Edwards <pme@gcc.gnu.org>2003-08-27 00:38:28 +0000
commit82ba99d59e56c2d0774c267624583341a96b681f (patch)
treedd98bcfa8b7c51e66c2927eed518cb1f935b1dc0 /libstdc++-v3/libsupc++/Makefile.am
parent48ab3fe3c9b005c32936ad338d45439a5e952931 (diff)
downloadgcc-82ba99d59e56c2d0774c267624583341a96b681f.tar.gz
Makefile.am: Add comment.
2003-08-26 Phil Edwards <pme@gcc.gnu.org> * Makefile.am: Add comment. * acinclude.m4 (GLIBCXX_CONFIGURE): Set new glibcxx_SUBDIRS and SUBDIRS variables. * configure.ac: Use them both here, instead of hardcoded lists. * fragment.am: Add STAMP varaible. * include/Makefile.am: Cosmetic whitespace cleanup. Use $(LN_S) instead of @LN_S@. (stamp-*): Move file creation rule outside of 'if' branches to ensure the stamp-* files are actually updated. Use $(STAMP). * src/Makefile.am: Remove now-nonexistant variable. * libsupc++/Makefile.am: Likewise. Snap the assignment chain for -prefer-pic. * po/Makefile.am: Include same fragment as all the others. * aclocal.m4, configure, Makefile.in, include/Makefile.in, libsupc++/Makefile.in, po/Makefile.in, src/Makefile.in: Regenerated. From-SVN: r70836
Diffstat (limited to 'libstdc++-v3/libsupc++/Makefile.am')
-rw-r--r--libstdc++-v3/libsupc++/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/libstdc++-v3/libsupc++/Makefile.am b/libstdc++-v3/libsupc++/Makefile.am
index 59f80fbe7e4..9ce80f9bb3b 100644
--- a/libstdc++-v3/libsupc++/Makefile.am
+++ b/libstdc++-v3/libsupc++/Makefile.am
@@ -31,9 +31,6 @@ toolexeclib_LTLIBRARIES = libsupc++.la
noinst_LTLIBRARIES = libsupc++convenience.la
-
-LIBSUPCXX_CXXFLAGS = @LIBSUPCXX_PICFLAGS@
-
headers = \
exception new typeinfo cxxabi.h exception_defines.h
@@ -78,7 +75,7 @@ glibcxxinstall_HEADERS = $(headers)
# as the occasion call for it.
AM_CXXFLAGS = \
-fno-implicit-templates \
- $(LIBSUPCXX_CXXFLAGS) \
+ $(LIBSUPCXX_PICFLAGS) \
$(WARN_CXXFLAGS) \
$(OPTIMIZE_CXXFLAGS) \
$(CONFIG_CXXFLAGS)