summaryrefslogtreecommitdiff
path: root/libjava/classpath/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libjava/classpath/configure.ac')
-rw-r--r--libjava/classpath/configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/libjava/classpath/configure.ac b/libjava/classpath/configure.ac
index a14d2c128c3..54a3efce22f 100644
--- a/libjava/classpath/configure.ac
+++ b/libjava/classpath/configure.ac
@@ -1059,9 +1059,8 @@ examples/Makefile
examples/Makefile.jawt
examples/Makefile.java2d])
-if test "x${COMPILE_WRAPPERS}" = xno
-then
-AC_CONFIG_FILES([tools/gappletviewer
+CLASSPATH_COND_IF([CREATE_WRAPPERS], [test "x${COMPILE_WRAPPERS}" = xyes], [],
+[AC_CONFIG_FILES([tools/gappletviewer
tools/gjarsigner
tools/gkeytool
tools/gjar
@@ -1073,6 +1072,7 @@ tools/gorbd
tools/grmid
tools/grmic
tools/gjavah])
+
AC_CONFIG_COMMANDS([gappletviewer],[chmod 755 tools/gappletviewer])
AC_CONFIG_COMMANDS([gjarsigner],[chmod 755 tools/gjarsigner])
AC_CONFIG_COMMANDS([gkeytool],[chmod 755 tools/gkeytool])
@@ -1085,7 +1085,7 @@ AC_CONFIG_COMMANDS([gorbd],[chmod 755 tools/gorbd])
AC_CONFIG_COMMANDS([grmid],[chmod 755 tools/grmid])
AC_CONFIG_COMMANDS([grmic],[chmod 755 tools/grmic])
AC_CONFIG_COMMANDS([gjavah], [chmod 755 tools/gjavah])
-fi
+])
AC_CONFIG_COMMANDS([gen-classlist],[chmod 755 lib/gen-classlist.sh])
AC_CONFIG_COMMANDS([copy-vmresources],[chmod 755 lib/copy-vmresources.sh])