summaryrefslogtreecommitdiff
path: root/libmudflap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmudflap/Makefile.am')
-rw-r--r--libmudflap/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/libmudflap/Makefile.am b/libmudflap/Makefile.am
index 7bcaeb5db66..639db4218d4 100644
--- a/libmudflap/Makefile.am
+++ b/libmudflap/Makefile.am
@@ -20,18 +20,29 @@ endif
toolexeclib_LTLIBRARIES = libmudflap.la $(libmudflapth)
include_HEADERS = mf-runtime.h
+# Copy this out of libiberty's source tree, so it can be built here via libtool
+splay-tree.c:
+ rm -f $@
+ $(LN_S) $(srcdir)/../libiberty/splay-tree.c $@
+# Copy this so that top-level include/ does not have to be put into -I path
+splay-tree.h:
+ rm -f $@
+ $(LN_S) $(srcdir)/../include/splay-tree.h $@
+
libmudflap_la_SOURCES = \
mf-runtime.c \
mf-heuristics.c \
mf-hooks1.c \
mf-hooks2.c
+mf-runtime.lo: mf-runtime.c splay-tree.c splay-tree.h
libmudflap_la_LIBADD =
libmudflap_la_DEPENDENCIES = $(libmudflap_la_LIBADD)
clean-local:
rm -f pth/*.o pth/*.lo
+ rm -f splay-tree.c splay-tree.h
-pth/mf-runtime.lo: mf-runtime.c mf-runtime.h mf-impl.h
+pth/mf-runtime.lo: mf-runtime.c mf-runtime.h mf-impl.h splay-tree.c splay-tree.h
$(LTCOMPILE) -DLIBMUDFLAPTH -c $(srcdir)/mf-runtime.c -o $@
pth/mf-heuristics.lo: mf-heuristics.c mf-runtime.h mf-impl.h
$(LTCOMPILE) -DLIBMUDFLAPTH -c $(srcdir)/mf-heuristics.c -o $@