summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2000-10-03 19:14:25 +0000
committerHavoc Pennington <hp@src.gnome.org>2000-10-03 19:14:25 +0000
commit99cc2d2cc853adee9495c9d0d6c8d555c253e35d (patch)
tree453b684637b1b03f3b2b97d80069a842a3b7ebf1 /Makefile.am
parent26425fc792e67f9f25fcc50e91d984c319886f5f (diff)
downloadgconf-99cc2d2cc853adee9495c9d0d6c8d555c253e35d.tar.gz
set invalid FILE* to NULL afterward, avoid segfaults.
2000-10-03 Havoc Pennington <hp@redhat.com> * gconf/gconfd.c (close_append_handle): set invalid FILE* to NULL afterward, avoid segfaults. * Makefile.am: add install-schemas target here which recurses into standard-schemas and runs install-schemas * standard-schemas/Makefile.am (install-schemas): Move schema installation to a special target install-schemas which must be run manually _after_ make install. This should resolve problems people are having with RPMs and such. However it means spec files have to explicitly add a 'make install-schemas'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 630edd21..60b02025 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,3 +25,5 @@ install-data-local:
echo $(WARNING_MESSAGE) && \
echo "**************"
+install-schemas:
+ (cd standard-schemas && $(MAKE) $(AM_MAKEFLAGS) install-schemas)