summaryrefslogtreecommitdiff
path: root/bfd/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>1999-05-27 21:42:14 +0000
committerIan Lance Taylor <ian@airs.com>1999-05-27 21:42:14 +0000
commit86686498644aa873d3721157ded867f9180177fa (patch)
treea769bb9c66cf881cbcd756f83ef0d51a003e9677 /bfd/Makefile.am
parenteac349f88849154db8d8e94379189def58e39f8e (diff)
downloadgdb-86686498644aa873d3721157ded867f9180177fa.tar.gz
1999-05-28 Martin Dorey <mdorey@madge.com>
* elf32-i960.c: New file. * elf.c (prep_headers): Handle bfd_arch_i960. * targets.c (bfd_target_vector): Add &bfd_elf32_i960_vec. * config.bfd (i960-*-elf*): New target. * configure.in (bfd_elf32_i960_vec): New target vector. * Makefile.am (BFD32_BACKENDS): Add elf32-i960.lo. (BFD32_BACKENDS_CFILES): Add elf32-i960.c. * Makefile.in, aclocal.m4, configure: Rebuild.
Diffstat (limited to 'bfd/Makefile.am')
-rw-r--r--bfd/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index a15531171d8..99ad5083c71 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -158,6 +158,7 @@ BFD32_BACKENDS = \
elf32-hppa.lo \
elf32-i386.lo \
elf32-i860.lo \
+ elf32-i960.lo \
elf32-m32r.lo \
elf32-m68k.lo \
elf32-m88k.lo \
@@ -276,6 +277,7 @@ BFD32_BACKENDS_CFILES = \
elf32-hppa.c \
elf32-i386.c \
elf32-i860.c \
+ elf32-i960.c \
elf32-m32r.c \
elf32-m68k.c \
elf32-m88k.c \
@@ -839,6 +841,9 @@ elf32-i386.lo: elf32-i386.c $(INCDIR)/bfdlink.h elf-bfd.h \
elf32-i860.lo: elf32-i860.c elf-bfd.h $(INCDIR)/elf/common.h \
$(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h $(INCDIR)/bfdlink.h \
elf32-target.h
+elf32-i960.lo: elf32-i960.c elf-bfd.h $(INCDIR)/elf/common.h \
+ $(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h $(INCDIR)/bfdlink.h \
+ $(INCDIR)/elf/i960.h $(INCDIR)/elf/reloc-macros.h elf32-target.h
elf32-m32r.lo: elf32-m32r.c elf-bfd.h $(INCDIR)/elf/common.h \
$(INCDIR)/elf/internal.h $(INCDIR)/elf/external.h $(INCDIR)/bfdlink.h \
$(INCDIR)/elf/m32r.h $(INCDIR)/elf/reloc-macros.h elf32-target.h