summaryrefslogtreecommitdiff
path: root/bfd/configure.in
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2001-10-02 05:58:41 +0000
committerAlan Modra <amodra@bigpond.net.au>2001-10-02 05:58:41 +0000
commit7b32183e89661fefa398160c1403307e41f34c64 (patch)
tree0fde50ab03802e672e8099fc1a55521147c512e4 /bfd/configure.in
parent4e344fae52f617af16e11345a77e5db797bc67d3 (diff)
downloadgdb-7b32183e89661fefa398160c1403307e41f34c64.tar.gz
* version.h: New file.
* bfd-in.h: (BFD_VERSION): Substitute bfd_version. (BFD_VERSION_DATE): Define. (BFD_VERSION_STRING): Define. * configure.in: AC_SUBST bfd_version, bfd_version_date and bfd_version_string. (AC_OUTPUT <bfd-in3.h>): Depend on version.h. * bfd-in2.h: Regenerate. * configure: Regenerate. * Makefile.am: Run "make dep-am" * Makefile.in: Regenerate. * bfd-in.h: Include "symcat.h". (CONCAT4): Redefine as for old CAT4. * aout-arm.c: Use equivalent CONCAT* macro in place of CAT* macros. Add warning regarding whitespace. * aout-cris.c: Likewise. * aout-ns32k.c: Likewise. * aout-sparcle.c: Likewise. * aout-tic30.c: Likewise. * aout0.c: Likewise. * armnetbsd.c: Likewise. * demo64.c: Likewise. * elf-bfd.h: Likewise. * gen-aout.c: Likewise. * host-aout.c: Likewise. * hp300bsd.c: Likewise. * hp300hpux.c: Likewise. * i386aout.c: Likewise. * i386bsd.c: Likewise. * i386dynix.c: Likewise. * i386freebsd.c: Likewise. * i386linux.c: Likewise. * i386lynx.c: Likewise. * i386mach3.c: Likewise. * i386netbsd.c: Likewise. * libaout.h: Likewise. * m68k4knetbsd.c: Likewise. * m68klinux.c: Likewise. * m68klynx.c: Likewise. * m68knetbsd.c: Likewise. * m88kmach3.c: Likewise. * mipsbsd.c: Likewise. * newsos3.c: Likewise. * ns32knetbsd.c: Likewise. * pc532-mach.c: Likewise. * pdp11.c: Likewise. * riscix.c: Likewise. * sparclinux.c: Likewise. * sparclynx.c: Likewise. * sparcnetbsd.c: Likewise. * sunos.c: Likewise. * targets.c: Likewise. * vaxnetbsd.c: Likewise. * vms-hdr.c: Likewise.
Diffstat (limited to 'bfd/configure.in')
-rw-r--r--bfd/configure.in22
1 files changed, 21 insertions, 1 deletions
diff --git a/bfd/configure.in b/bfd/configure.in
index 081fe083765..d71f45f2ada 100644
--- a/bfd/configure.in
+++ b/bfd/configure.in
@@ -8,6 +8,26 @@ AC_CANONICAL_SYSTEM
AC_ISC_POSIX
AM_INIT_AUTOMAKE(bfd, 2.11.92)
+# Uncomment the next line to remove the date from the reported bfd version
+#is_release=y
+
+changequote(,)dnl
+bfd_version=`echo "${VERSION}" | sed -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$/\1\2\3\4\5/'`
+changequote([,])dnl
+
+bfd_version_string="\"${VERSION}\""
+bfd_version_date=`sed -e 's/.*DATE //' < ${srcdir}/version.h`
+if test x${is_release} = x; then
+dnl Sad, but we can't use XSTRING here to pick up the date from version.h
+dnl because traditional C doesn't allow it.
+ bfd_version_string="\"${VERSION} ${bfd_version_date}\""
+fi
+dnl Since we need to edit bfd-in3.h to get the date for bfd_version_string,
+dnl we may as well substitute for bfd_version_date too. That way we don't
+dnl need to #include version.h
+AC_SUBST(bfd_version)
+AC_SUBST(bfd_version_date)
+AC_SUBST(bfd_version_string)
dnl These must be called before AM_PROG_LIBTOOL, because it may want
dnl to call AC_CHECK_PROG.
@@ -751,6 +771,6 @@ case ${want_mmap}+${ac_cv_func_mmap_fixed_mapped} in
esac
rm -f doc/config.status
-AC_OUTPUT(Makefile doc/Makefile bfd-in3.h:bfd-in2.h po/Makefile.in:po/Make-in,
+AC_OUTPUT(Makefile doc/Makefile bfd-in3.h:bfd-in2.h:version.h po/Makefile.in:po/Make-in,
[sed -e '/SRC-POTFILES =/r po/SRC-POTFILES' -e '/BLD-POTFILES =/r po/BLD-POTFILES' po/Makefile.in > po/Makefile])