summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2012-06-28 11:50:52 +0000
committerAlexandre Oliva <aoliva@redhat.com>2012-06-28 11:50:52 +0000
commit3371bc075199aa2b4b555d353890e509c26af6ba (patch)
treeca94a7e3bb39bab4e7ef6a846147d0f0e99fa22d /configure.ac
parentf790ccd747cd70e530d8ba4c50a9923ffa8504bd (diff)
downloadgdb-3371bc075199aa2b4b555d353890e509c26af6ba.tar.gz
* configure.ac (CFLAGS_FOR_TARGET, CXXFLAGS_FOR_TARGET): Make sure
they contain -O2. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 224127c1d9b..5efb4a32f11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2125,11 +2125,11 @@ if test "x$CFLAGS_FOR_TARGET" = x; then
CFLAGS_FOR_TARGET=$CFLAGS
case " $CFLAGS " in
*" -O2 "*) ;;
- *) CFLAGS_FOR_TARGET="-O2 $CFLAGS" ;;
+ *) CFLAGS_FOR_TARGET="-O2 $CFLAGS_FOR_TARGET" ;;
esac
case " $CFLAGS " in
*" -g "* | *" -g3 "*) ;;
- *) CFLAGS_FOR_TARGET="-g $CFLAGS" ;;
+ *) CFLAGS_FOR_TARGET="-g $CFLAGS_FOR_TARGET" ;;
esac
fi
AC_SUBST(CFLAGS_FOR_TARGET)
@@ -2138,11 +2138,11 @@ if test "x$CXXFLAGS_FOR_TARGET" = x; then
CXXFLAGS_FOR_TARGET=$CXXFLAGS
case " $CXXFLAGS " in
*" -O2 "*) ;;
- *) CXXFLAGS_FOR_TARGET="-O2 $CXXFLAGS" ;;
+ *) CXXFLAGS_FOR_TARGET="-O2 $CXXFLAGS_FOR_TARGET" ;;
esac
case " $CXXFLAGS " in
*" -g "* | *" -g3 "*) ;;
- *) CXXFLAGS_FOR_TARGET="-g $CXXFLAGS" ;;
+ *) CXXFLAGS_FOR_TARGET="-g $CXXFLAGS_FOR_TARGET" ;;
esac
fi
AC_SUBST(CXXFLAGS_FOR_TARGET)