summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Schwab <schwab@suse.de>2011-01-21 13:29:46 +0000
committerAndreas Schwab <schwab@suse.de>2011-01-21 13:29:46 +0000
commit3ee1ceb823158a147782c07543457b39fffb4e88 (patch)
tree4dd8ab5b81ee2c07667d981a6a67a2090435a8d0 /configure.ac
parenta6c859acc211788f210ce8505afa9d75b71f981e (diff)
downloadgdb-3ee1ceb823158a147782c07543457b39fffb4e88.tar.gz
Sync toplevel configure from GCC
2011-01-21 Andreas Schwab <schwab@redhat.com> * configure.ac: Use AS_HELP_STRING throughout. * configure: Regenerate. 2011-01-18 Jie Zhang <jie.zhang@analog.com> * configure.ac (bfin-*-*): Remove gdb from noconfigdirs. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac170
1 files changed, 103 insertions, 67 deletions
diff --git a/configure.ac b/configure.ac
index c7a86e2b6db..1227054fb5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
-# 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010
+# 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011
# Free Software Foundation, Inc.
#
# This file is free software; you can redistribute it and/or modify it
@@ -344,7 +344,8 @@ esac
default_ld=
AC_ARG_ENABLE(gold,
-[[ --enable-gold[=ARG] build gold [ARG={default,yes,no}]]],
+[AS_HELP_STRING([[--enable-gold[=ARG]]],
+ [build gold @<:@ARG={default,yes,no}@:>@])],
ENABLE_GOLD=$enableval,
ENABLE_GOLD=no)
case "${ENABLE_GOLD}" in
@@ -385,7 +386,8 @@ case "${ENABLE_GOLD}" in
esac
AC_ARG_ENABLE(ld,
-[[ --enable-ld[=ARG] build ld [ARG={default,yes,no}]]],
+[AS_HELP_STRING([[--enable-ld[=ARG]]],
+ [build ld @<:@ARG={default,yes,no}@:>@])],
ENABLE_LD=$enableval,
ENABLE_LD=yes)
@@ -480,7 +482,7 @@ fi
AC_ARG_ENABLE(libada,
-[ --enable-libada build libada directory],
+[AS_HELP_STRING([--enable-libada], [build libada directory])],
ENABLE_LIBADA=$enableval,
ENABLE_LIBADA=yes)
if test "${ENABLE_LIBADA}" != "yes" ; then
@@ -488,7 +490,7 @@ if test "${ENABLE_LIBADA}" != "yes" ; then
fi
AC_ARG_ENABLE(libssp,
-[ --enable-libssp build libssp directory],
+[AS_HELP_STRING([--enable-libssp], [build libssp directory])],
ENABLE_LIBSSP=$enableval,
ENABLE_LIBSSP=yes)
@@ -711,7 +713,7 @@ case "${target}" in
;;
bfin-*-*)
unsupported_languages="$unsupported_languages java"
- noconfigdirs="$noconfigdirs target-boehm-gc gdb"
+ noconfigdirs="$noconfigdirs target-boehm-gc"
if test x${is_cross_compiler} != xno ; then
target_configdirs="${target_configdirs} target-bsp target-cygmon"
fi
@@ -1320,7 +1322,8 @@ ACX_PROG_CMP_IGNORE_INITIAL
# See if we are building gcc with C++.
AC_ARG_ENABLE(build-with-cxx,
-[ --enable-build-with-cxx build with C++ compiler instead of C compiler],
+[AS_HELP_STRING([--enable-build-with-cxx],
+ [build with C++ compiler instead of C compiler])],
ENABLE_BUILD_WITH_CXX=$enableval,
ENABLE_BUILD_WITH_CXX=no)
@@ -1334,12 +1337,17 @@ have_gmp=no
# Specify a location for mpc
# check for this first so it ends up on the link line before mpfr.
-AC_ARG_WITH(mpc, [ --with-mpc=PATH specify prefix directory for installed MPC package.
- Equivalent to --with-mpc-include=PATH/include
- plus --with-mpc-lib=PATH/lib])
-AC_ARG_WITH(mpc-include, [ --with-mpc-include=PATH
- specify directory for installed MPC include files])
-AC_ARG_WITH(mpc-lib, [ --with-mpc-lib=PATH specify directory for the installed MPC library])
+AC_ARG_WITH(mpc,
+[AS_HELP_STRING([--with-mpc=PATH],
+ [specify prefix directory for installed MPC package.
+ Equivalent to --with-mpc-include=PATH/include
+ plus --with-mpc-lib=PATH/lib])])
+AC_ARG_WITH(mpc-include,
+[AS_HELP_STRING([--with-mpc-include=PATH],
+ [specify directory for installed MPC include files])])
+AC_ARG_WITH(mpc-lib,
+[AS_HELP_STRING([--with-mpc-lib=PATH],
+ [specify directory for the installed MPC library])])
if test "x$with_mpc" != x; then
gmplibs="-L$with_mpc/lib $gmplibs"
@@ -1363,16 +1371,22 @@ fi
# Specify a location for mpfr
# check for this first so it ends up on the link line before gmp.
-AC_ARG_WITH(mpfr-dir, [ --with-mpfr-dir=PATH this option has been REMOVED],
- AC_MSG_ERROR([The --with-mpfr-dir=PATH option has been removed.
-Use --with-mpfr=PATH or --with-mpfr-include=PATH plus --with-mpfr-lib=PATH]))
-
-AC_ARG_WITH(mpfr, [ --with-mpfr=PATH specify prefix directory for installed MPFR package.
- Equivalent to --with-mpfr-include=PATH/include
- plus --with-mpfr-lib=PATH/lib])
-AC_ARG_WITH(mpfr-include, [ --with-mpfr-include=PATH
- specify directory for installed MPFR include files])
-AC_ARG_WITH(mpfr-lib, [ --with-mpfr-lib=PATH specify directory for the installed MPFR library])
+AC_ARG_WITH(mpfr-dir,
+[AS_HELP_STRING([--with-mpfr-dir=PATH], [this option has been REMOVED])],
+[AC_MSG_ERROR([The --with-mpfr-dir=PATH option has been removed.
+Use --with-mpfr=PATH or --with-mpfr-include=PATH plus --with-mpfr-lib=PATH])])
+
+AC_ARG_WITH(mpfr,
+[AS_HELP_STRING([--with-mpfr=PATH],
+ [specify prefix directory for installed MPFR package.
+ Equivalent to --with-mpfr-include=PATH/include
+ plus --with-mpfr-lib=PATH/lib])])
+AC_ARG_WITH(mpfr-include,
+[AS_HELP_STRING([--with-mpfr-include=PATH],
+ [specify directory for installed MPFR include files])])
+AC_ARG_WITH(mpfr-lib,
+[AS_HELP_STRING([--with-mpfr-lib=PATH],
+ [specify directory for the installed MPFR library])])
if test "x$with_mpfr" != x; then
gmplibs="-L$with_mpfr/lib $gmplibs"
@@ -1396,15 +1410,22 @@ if test "x$with_mpfr$with_mpfr_include$with_mpfr_lib" = x && test -d ${srcdir}/m
fi
# Specify a location for gmp
-AC_ARG_WITH(gmp-dir, [ --with-gmp-dir=PATH this option has been REMOVED],
- AC_MSG_ERROR([The --with-gmp-dir=PATH option has been removed.
-Use --with-gmp=PATH or --with-gmp-include=PATH plus --with-gmp-lib=PATH]))
-
-AC_ARG_WITH(gmp, [ --with-gmp=PATH specify prefix directory for the installed GMP package.
- Equivalent to --with-gmp-include=PATH/include
- plus --with-gmp-lib=PATH/lib])
-AC_ARG_WITH(gmp-include, [ --with-gmp-include=PATH specify directory for installed GMP include files])
-AC_ARG_WITH(gmp-lib, [ --with-gmp-lib=PATH specify directory for the installed GMP library])
+AC_ARG_WITH(gmp-dir,
+[AS_HELP_STRING([--with-gmp-dir=PATH], [this option has been REMOVED])],
+[AC_MSG_ERROR([The --with-gmp-dir=PATH option has been removed.
+Use --with-gmp=PATH or --with-gmp-include=PATH plus --with-gmp-lib=PATH])])
+
+AC_ARG_WITH(gmp,
+[AS_HELP_STRING([--with-gmp=PATH],
+ [specify prefix directory for the installed GMP package.
+ Equivalent to --with-gmp-include=PATH/include
+ plus --with-gmp-lib=PATH/lib])])
+AC_ARG_WITH(gmp-include,
+[AS_HELP_STRING([--with-gmp-include=PATH],
+ [specify directory for installed GMP include files])])
+AC_ARG_WITH(gmp-lib,
+[AS_HELP_STRING([--with-gmp-lib=PATH],
+ [specify directory for the installed GMP library])])
if test "x$with_gmp" != x; then
@@ -1536,8 +1557,10 @@ AC_SUBST(extra_mpc_gmp_configure_flags)
AC_SUBST(extra_mpc_mpfr_configure_flags)
# Allow host libstdc++ to be specified for static linking with PPL.
-AC_ARG_WITH(host-libstdcxx, [ --with-host-libstdcxx=L Use linker arguments L to link with libstdc++
- when linking with PPL])
+AC_ARG_WITH(host-libstdcxx,
+[AS_HELP_STRING([--with-host-libstdcxx=L],
+ [use linker arguments L to link with libstdc++
+ when linking with PPL])])
case $with_host_libstdcxx in
no|yes)
@@ -1547,7 +1570,7 @@ esac
# Linker flags to use for stage1 or when not boostrapping.
AC_ARG_WITH(stage1-ldflags,
-[ --with-stage1-ldflags=FLAGS Linker flags for stage1],
+[AS_HELP_STRING([--with-stage1-ldflags=FLAGS], [linker flags for stage1])],
[if test "$withval" = "no" -o "$withval" = "yes"; then
stage1_ldflags=
else
@@ -1558,7 +1581,7 @@ AC_SUBST(stage1_ldflags)
# Libraries to use for stage1 or when not bootstrapping.
AC_ARG_WITH(stage1-libs,
-[ -with-stage1-libs=LIBS Libraries for stage1],
+[AS_HELP_STRING([--with-stage1-libs=LIBS], [libraries for stage1])],
[if test "$withval" = "no" -o "$withval" = "yes"; then
stage1_libs=
else
@@ -1570,7 +1593,7 @@ AC_SUBST(stage1_libs)
# Libraries to use for stage2 and later builds. This defaults to the
# argument passed to --with-host-libstdcxx.
AC_ARG_WITH(boot-libs,
-[ --with-boot-libs=LIBS Libraries for stage2 and later],
+[AS_HELP_STRING([--with-boot-libs=LIBS], [libraries for stage2 and later])],
[if test "$withval" = "no" -o "$withval" = "yes"; then
poststage1_libs=
else
@@ -1581,7 +1604,8 @@ AC_SUBST(poststage1_libs)
# Linker flags to use for stage2 and later builds.
AC_ARG_WITH(boot-ldflags,
-[ --with-boot-ldflags=FLAGS Linker flags for stage2 and later],
+[AS_HELP_STRING([--with-boot-ldflags=FLAGS],
+ [linker flags for stage2 and later])],
[if test "$withval" = "no" -o "$withval" = "yes"; then
poststage1_ldflags=
else
@@ -1600,11 +1624,17 @@ AC_SUBST(poststage1_ldflags)
ppllibs=" -lppl_c -lppl -lgmpxx"
pplinc=
-AC_ARG_WITH(ppl, [ --with-ppl=PATH Specify prefix directory for the installed PPL package
- Equivalent to --with-ppl-include=PATH/include
- plus --with-ppl-lib=PATH/lib])
-AC_ARG_WITH(ppl-include, [ --with-ppl-include=PATH Specify directory for installed PPL include files])
-AC_ARG_WITH(ppl-lib, [ --with-ppl-lib=PATH Specify the directory for the installed PPL library])
+AC_ARG_WITH(ppl,
+[AS_HELP_STRING([--with-ppl=PATH],
+ [specify prefix directory for the installed PPL package.
+ Equivalent to --with-ppl-include=PATH/include
+ plus --with-ppl-lib=PATH/lib])])
+AC_ARG_WITH(ppl-include,
+[AS_HELP_STRING([--with-ppl-include=PATH],
+ [specify directory for installed PPL include files])])
+AC_ARG_WITH(ppl-lib,
+[AS_HELP_STRING([--with-ppl-lib=PATH],
+ [specify directory for the installed PPL library])])
case $with_ppl in
no)
@@ -1630,7 +1660,8 @@ if test "x$with_ppl$with_ppl_include$with_ppl_lib" = x && test -d ${srcdir}/ppl;
fi
AC_ARG_ENABLE(ppl-version-check,
-[ --disable-ppl-version-check disable check for PPL version],
+[AS_HELP_STRING([--disable-ppl-version-check],
+ [disable check for PPL version])],
ENABLE_PPL_CHECK=$enableval,
ENABLE_PPL_CHECK=yes)
@@ -1687,7 +1718,7 @@ fi
# Check for LTO support.
AC_ARG_ENABLE(lto,
-[ --enable-lto enable link time optimization support],
+[AS_HELP_STRING([--enable-lto], [enable link time optimization support])],
enable_lto=$enableval,
enable_lto=yes; default_enable_lto=yes)
@@ -1948,8 +1979,9 @@ if test -d ${srcdir}/gcc; then
fi
AC_ARG_ENABLE(stage1-languages,
-[ --enable-stage1-languages@<:@=all@:>@ choose additional languages to build during
- stage1. Mostly useful for compiler development.],
+ [AS_HELP_STRING([[--enable-stage1-languages[=all]]],
+ [choose additional languages to build during
+ stage1. Mostly useful for compiler development])],
[case ,${enable_stage1_languages}, in
,no,|,,)
# Set it to something that will have no effect in the loop below
@@ -2010,8 +2042,9 @@ done
# Check for Boehm's garbage collector
AC_ARG_ENABLE(objc-gc,
-[ --enable-objc-gc enable use of Boehm's garbage collector with the
- GNU Objective-C runtime],
+[AS_HELP_STRING([--enable-objc-gc],
+ [enable use of Boehm's garbage collector with the
+ GNU Objective-C runtime])],
[case ,${enable_languages},:${enable_objc_gc}:${noconfigdirs} in
*,objc,*:*:yes:*target-boehm-gc*)
AC_MSG_ERROR([Boehm's garbage collector was requested yet not supported in this configuration])
@@ -2166,8 +2199,8 @@ ACX_TOOL_DIRS
copy_dirs=
AC_ARG_WITH([build-sysroot],
- [ --with-build-sysroot=SYSROOT
- use sysroot as the system root during the build],
+ [AS_HELP_STRING([--with-build-sysroot=SYSROOT],
+ [use sysroot as the system root during the build])],
[if test x"$withval" != x ; then
SYSROOT_CFLAGS_FOR_TARGET="--sysroot=$withval"
fi],
@@ -2175,8 +2208,8 @@ AC_ARG_WITH([build-sysroot],
AC_SUBST(SYSROOT_CFLAGS_FOR_TARGET)
AC_ARG_WITH([debug-prefix-map],
- [ --with-debug-prefix-map='A=B C=D ...'
- map A to B, C to D ... in debug information],
+ [AS_HELP_STRING([--with-debug-prefix-map='A=B C=D ...'],
+ [map A to B, C to D ... in debug information])],
[if test x"$withval" != x; then
DEBUG_PREFIX_CFLAGS_FOR_TARGET=
for debug_map in $withval; do
@@ -2605,7 +2638,8 @@ INSTALL_GDB_TK=`echo ${GDB_TK} | sed s/-all-/-install-/g`
# Do not nest @if/@endif pairs, because configure will not warn you at all.
AC_ARG_ENABLE([bootstrap],
-[ --enable-bootstrap enable bootstrapping @<:@yes if native build@:>@],,
+[AS_HELP_STRING([--enable-bootstrap],
+ [enable bootstrapping @<:@yes if native build@:>@])],,
enable_bootstrap=default)
# Issue errors and warnings for invalid/strange bootstrap combinations.
@@ -2674,8 +2708,8 @@ esac
AC_MSG_CHECKING(for default BUILD_CONFIG)
AC_ARG_WITH([build-config],
- [--with-build-config='NAME NAME2...'
- Use config/NAME.mk build configuration],
+ [AS_HELP_STRING([--with-build-config='NAME NAME2...'],
+ [use config/NAME.mk build configuration])],
[case $with_build_config in
yes) with_build_config= ;;
no) with_build_config= BUILD_CONFIG= ;;
@@ -2760,10 +2794,10 @@ extrasub_target="$extrasub_target
# Create the serialization dependencies. This uses a temporary file.
AC_ARG_ENABLE([serial-configure],
-[ --enable-serial-@<:@{host,target,build}-@:>@configure
- force sequential configuration of
- sub-packages for the host, target or build
- machine, or all sub-packages])
+[AS_HELP_STRING([[--enable-serial-[{host,target,build}-]configure]],
+ [force sequential configuration of
+ sub-packages for the host, target or build
+ machine, or all sub-packages])])
case ${enable_serial_configure} in
yes)
@@ -3227,8 +3261,8 @@ AC_SUBST(CXXFLAGS)
# Target tools.
AC_ARG_WITH([build-time-tools],
- [ --with-build-time-tools=PATH
- use given path to find target tools during the build],
+ [AS_HELP_STRING([--with-build-time-tools=PATH],
+ [use given path to find target tools during the build])],
[case x"$withval" in
x/*) ;;
*)
@@ -3315,8 +3349,9 @@ AC_SUBST(COMPILER_NM_FOR_TARGET)
AC_MSG_CHECKING([whether to enable maintainer-specific portions of Makefiles])
AC_ARG_ENABLE(maintainer-mode,
-[ --enable-maintainer-mode enable make rules and dependencies not useful
- (and sometimes confusing) to the casual installer],
+[AS_HELP_STRING([--enable-maintainer-mode],
+ [enable make rules and dependencies not useful
+ (and sometimes confusing) to the casual installer])],
USE_MAINTAINER_MODE=$enableval,
USE_MAINTAINER_MODE=no)
AC_MSG_RESULT($USE_MAINTAINER_MODE)
@@ -3370,8 +3405,8 @@ AC_SUBST(stage1_cflags)
# Enable --enable-checking in stage1 of the compiler.
AC_ARG_ENABLE(stage1-checking,
-[ --enable-stage1-checking@<:@=all@:>@ choose additional checking for stage1
- of the compiler],
+[AS_HELP_STRING([[--enable-stage1-checking[=all]]],
+ [choose additional checking for stage1 of the compiler])],
[stage1_checking=--enable-checking=${enable_stage1_checking}],
[if test "x$enable_checking" = xno || test "x$enable_checking" = x; then
stage1_checking=--enable-checking=yes,types
@@ -3382,7 +3417,8 @@ AC_SUBST(stage1_checking)
# Enable -Werror in bootstrap stage2 and later.
AC_ARG_ENABLE(werror,
-[ --enable-werror enable -Werror in bootstrap stage2 and later], [],
+[AS_HELP_STRING([--enable-werror],
+ [enable -Werror in bootstrap stage2 and later])], [],
[if test -d ${srcdir}/gcc && test x"`cat $srcdir/gcc/DEV-PHASE`" = xexperimental; then
enable_werror=yes
else