summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Botcazou <ebotcazou@libertysurf.fr>2012-10-23 23:02:33 +0000
committerEric Botcazou <ebotcazou@libertysurf.fr>2012-10-23 23:02:33 +0000
commit59edf67862d31cd6ee25248d4492c2924201f54d (patch)
tree8739687040a93201a3ca964bc17bdb0f206e83e3 /configure.ac
parentf92a5d158b60347eb72ebfbb8ec231bdd42483ac (diff)
downloadgdb-59edf67862d31cd6ee25248d4492c2924201f54d.tar.gz
PR bootstrap/54820
* configure.ac (have_static_libs): Force 'no' for GCC version < 4.5. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 958eadd5e78..c6665a1f33a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1190,7 +1190,11 @@ if test "$GCC" = yes; then
LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
AC_MSG_CHECKING([whether g++ accepts -static-libstdc++ -static-libgcc])
AC_LANG_PUSH(C++)
- AC_LINK_IFELSE([int main() {}],
+ AC_LINK_IFELSE([
+#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
+#error -static-libstdc++ not implemented
+#endif
+int main() {}],
[AC_MSG_RESULT([yes]); have_static_libs=yes],
[AC_MSG_RESULT([no])])
AC_LANG_POP(C++)