summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2010-12-07 21:20:22 +0000
committerIan Lance Taylor <ian@airs.com>2010-12-07 21:20:22 +0000
commit68db70f05288f15c45bd62a8de6e84677f0fb985 (patch)
tree072ab81aa51db92e386a52e3db93c64c52a7ea12 /configure.ac
parent063caa6468033583e6ba78c8f88273de2c0ebb92 (diff)
downloadgdb-68db70f05288f15c45bd62a8de6e84677f0fb985.tar.gz
* configure.ac: Always set default for poststage1_ldflags to
-static-libstdc++ -static-libgcc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 440f066acbe..fcf5ba2c7c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1561,10 +1561,10 @@ AC_ARG_WITH(boot-ldflags,
poststage1_ldflags=$withval
fi],
[poststage1_ldflags=
- # With --enable-build-with-cxx, default to linking libstdc++ and
- # libgcc statically. But if the user explicitly specified the
- # libraries to use, trust that they are doing what they want.
- if test "$ENABLE_BUILD_WITH_CXX" = "yes" -a "$poststage1_libs" = ""; then
+ # In stages 2 and 3, default to linking libstdc++ and libgcc
+ # statically. But if the user explicitly specified the libraries to
+ # use, trust that they are doing what they want.
+ if test "$poststage1_libs" = ""; then
poststage1_ldflags="-static-libstdc++ -static-libgcc"
fi])
AC_SUBST(poststage1_ldflags)