summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaolo Bonzini <bonzini@gnu.org>2011-03-24 17:31:09 +0000
committerPaolo Bonzini <bonzini@gnu.org>2011-03-24 17:31:09 +0000
commit6fd457c9285c5fd2c5a08644161c1eb7a053a30f (patch)
tree32949696afee8db311e0ac3b7dc01f2a19fdef2d /configure.ac
parent3cabe54fac4c6fdb8c37a65a012acb1e1b9f8015 (diff)
downloadgdb-6fd457c9285c5fd2c5a08644161c1eb7a053a30f.tar.gz
2011-03-24 Paolo Bonzini <bonzini@gnu.org>
Sync from GCC: 2011-03-24 Paolo Bonzini <bonzini@gnu.org> * configure.ac: Remove empty cases. * configure: Regenerate. 2011-03-24 Paolo Bonzini <bonzini@gnu.org> * Makefile.def: Add dependency from termcap to gdb. * Makefile.in: Regenerate. 2011-03-24 Paolo Bonzini <bonzini@gnu.org> * configure.ac: Remove all mentions of mh-sysv4 and mh-solaris. * configure: Regenerate. * Makefile.def: Remove all mentions of X11_FLAGS_TO_PASS. * Makefile.tpl: Likewise. * Makefile.in: Regenerate. 2011-03-24 Paolo Bonzini <bonzini@gnu.org> * configure.ac: Remove all mentions of tentative_cc. * configure: Regenerate. 2011-03-16 Jack Howarth <howarth@bromo.med.uc.edu> PR lto/48086 * configure.ac: Re-enable LTO on *-apple-darwin9. * configure: Regenerate. config: 2011-03-24 Paolo Bonzini <bonzini@gnu.org> Sync from GCC: 2011-03-24 Paolo Bonzini <bonzini@gnu.org> * mh-cygwin: Remove obsolete variables and dependencies. 2011-03-24 Paolo Bonzini <bonzini@gnu.org> * mh-sysv4: Remove. * mh-solaris: Remove. 2011-03-24 Paolo Bonzini <bonzini@gnu.org> * mh-sysv4: Remove AR_CFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 1 insertions, 41 deletions
diff --git a/configure.ac b/configure.ac
index b43a6652e5c..78abc7c2d85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1034,13 +1034,9 @@ case "${noconfigdirs}" in
esac
# Work in distributions that contain no compiler tools, like Autoconf.
-tentative_cc=""
host_makefile_frag=/dev/null
if test -d ${srcdir}/config ; then
case "${host}" in
- i[[3456789]]86-*-solaris2*)
- host_makefile_frag="config/mh-sysv4"
- ;;
i[[3456789]]86-*-msdosdjgpp*)
host_makefile_frag="config/mh-djgpp"
;;
@@ -1054,23 +1050,15 @@ case "${host}" in
*-interix*)
host_makefile_frag="config/mh-interix"
;;
- *-*-solaris2*)
- host_makefile_frag="config/mh-solaris"
- ;;
hppa*-hp-hpux10*)
- tentative_cc="cc -Wp,-H256000"
host_makefile_frag="config/mh-pa-hpux10"
;;
hppa*-hp-hpux*)
- tentative_cc="cc -Wp,-H256000"
host_makefile_frag="config/mh-pa"
;;
hppa*-*)
host_makefile_frag="config/mh-pa"
;;
- *-hp-hpux*)
- tentative_cc="cc -Wp,-H256000"
- ;;
*-*-darwin*)
host_makefile_frag="config/mh-darwin"
;;
@@ -1080,37 +1068,9 @@ case "${host}" in
rs6000-*-aix*)
host_makefile_frag="config/mh-ppc-aix"
;;
- *-*-lynxos*)
- # /bin/cc is less than useful for our purposes. Always use GCC
- tentative_cc="/bin/gcc"
- ;;
- # This is placed last to prevent interfering with the cases above.
- i[[3456789]]86-*-*)
- # Build the stage2 and stage3 compilers with -fomit-frame-pointer.
- host_makefile_frag="config/mh-x86omitfp"
- ;;
esac
fi
-# If we aren't going to be using gcc, see if we can extract a definition
-# of CC from the fragment.
-# Actually, use the 'pre-extracted' version above.
-if test -z "${CC}" && test "${build}" = "${host}" ; then
- IFS="${IFS= }"; save_ifs="$IFS"; IFS="${IFS}:"
- found=
- for dir in $PATH; do
- test -z "$dir" && dir=.
- if test -f $dir/gcc; then
- found=yes
- break
- fi
- done
- IFS="$save_ifs"
- if test -z "${found}" && test -n "${tentative_cc}" ; then
- CC=$tentative_cc
- fi
-fi
-
if test "${build}" != "${host}" ; then
AR_FOR_BUILD=${AR_FOR_BUILD-ar}
AS_FOR_BUILD=${AS_FOR_BUILD-as}
@@ -1589,7 +1549,7 @@ ACX_ELF_TARGET_IFELSE([# ELF platforms build the lto-plugin always.
build_lto_plugin=yes
],[if test x"$default_enable_lto" = x"yes" ; then
case $target in
- *-apple-darwin* | *-cygwin* | *-mingw*) ;;
+ *-apple-darwin9 | *-cygwin* | *-mingw*) ;;
# On other non-ELF platforms, LTO has yet to be validated.
*) enable_lto=no ;;
esac