summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2010-06-01 17:28:06 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2010-06-01 17:28:06 +0000
commit71446863f3bab5e57587fa01977f6fbf92909cd9 (patch)
tree0740b909ff38fb2b1386447981a60102317d0b29 /configure.ac
parentf06978eb333ee367789268251cd7ce393705891c (diff)
downloadgdb-71446863f3bab5e57587fa01977f6fbf92909cd9.tar.gz
Sync toplevel files from GCC.
/: Sync from GCC: 2010-05-05 Sebastian Pop <sebastian.pop@amd.com> * configure.ac: Allow all the versions greater than 0.10 of PPL. * configure: Regenerated. 2010-04-20 Eric Botcazou <ebotcazou@adacore.com> * configure.ac (BUILD_CONFIG): Redirect output to /dev/null. * configure: Regenerate. 2010-04-17 Ralf Corsépius <ralf.corsepius@rtems.org> * configure.ac (*-*-rtems*): Add target-libiberty to $skipdirs. * configure: Regenerate. 2010-04-16 Rainer Orth <ro@CeBiTec.Uni-Bielefeld.DE> * configure.ac: Check for elf_getshdrstrndx or elf_getshstrndx separately. * configure: Regenerate. 2010-04-13 Steve Ellcey <sje@cup.hp.com> * configure: Regenerate after change to elf.m4. 2010-04-02 Sebastian Pop <sebastian.pop@amd.com> * configure.ac: Add brackets around AC_TRY_COMPILE alternative. * configure: Regenerated. 2010-04-02 Sebastian Pop <sebastian.pop@amd.com> * configure.ac: Print "buggy but acceptable" when CLooG revision is less than 9. * configure: Regenerated. config/: Sync from GCC: 2010-04-13 Steve Ellcey <sje@cup.hp.com> * elf.m4: Add hppa[12]*-*-hpux* to list of non-elf platforms. 2010-01-05 Rainer Orth <ro@CeBiTec.Uni-Bielefeld.DE> * stdint.m4 (GCC_HEADER_STDINT): Don't typedef uint8_t etc. if corresponding macros already exist. bfd/: * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 37 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 507ab547b53..f78c5273084 100644
--- a/configure.ac
+++ b/configure.ac
@@ -548,6 +548,7 @@ case "${target}" in
noconfigdirs="$noconfigdirs target-newlib target-libiberty target-libgloss ${libgcj} target-libmudflap"
;;
*-*-rtems*)
+ skipdirs="${skipdirs} target-libiberty"
noconfigdirs="$noconfigdirs target-libgloss ${libgcj}"
;;
# The tpf target doesn't support gdb yet.
@@ -1374,13 +1375,13 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
#if GCC_GMP_VERSION < GCC_GMP_VERSION_NUM(4,2,0)
choke me
#endif
- ], AC_TRY_COMPILE([#include <gmp.h>],[
+ ], [AC_TRY_COMPILE([#include <gmp.h>],[
#define GCC_GMP_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
#define GCC_GMP_VERSION GCC_GMP_VERSION_NUM(__GNU_MP_VERSION,__GNU_MP_VERSION_MINOR,__GNU_MP_VERSION_PATCHLEVEL)
#if GCC_GMP_VERSION < GCC_GMP_VERSION_NUM(4,3,2)
choke me
#endif
- ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])]),
+ ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])])],
[AC_MSG_RESULT([no]); have_gmp=no])
# If we have GMP, check the MPFR version.
@@ -1392,12 +1393,12 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
#if MPFR_VERSION < MPFR_VERSION_NUM(2,3,1)
choke me
#endif
- ], AC_TRY_COMPILE([#include <gmp.h>
+ ], [AC_TRY_COMPILE([#include <gmp.h>
#include <mpfr.h>],[
#if MPFR_VERSION < MPFR_VERSION_NUM(2,4,2)
choke me
#endif
- ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])]),
+ ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])])],
[AC_MSG_RESULT([no]); have_gmp=no])
fi
@@ -1409,11 +1410,11 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
#if MPC_VERSION < MPC_VERSION_NUM(0,8,0)
choke me
#endif
- ], AC_TRY_COMPILE([#include <mpc.h>],[
+ ], [AC_TRY_COMPILE([#include <mpc.h>],[
#if MPC_VERSION < MPC_VERSION_NUM(0,8,1)
choke me
#endif
- ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])]),
+ ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])])],
[AC_MSG_RESULT([no]); have_gmp=no])
fi
@@ -1530,8 +1531,6 @@ AC_ARG_WITH(boot-ldflags,
AC_SUBST(poststage1_ldflags)
# Check for PPL
-ppl_major_version=0
-ppl_minor_version=10
ppllibs=" -lppl_c -lppl -lgmpxx"
pplinc=
@@ -1572,9 +1571,9 @@ ENABLE_PPL_CHECK=yes)
if test "x$with_ppl" != "xno" -a "${ENABLE_PPL_CHECK}" = "yes"; then
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $pplinc $gmpinc"
- AC_MSG_CHECKING([for version $ppl_major_version.$ppl_minor_version of PPL])
+ AC_MSG_CHECKING([for version 0.10 (or later revision) of PPL])
AC_TRY_COMPILE([#include "ppl_c.h"],[
- #if PPL_VERSION_MAJOR != $ppl_major_version || PPL_VERSION_MINOR != $ppl_minor_version
+ #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 10
choke me
#endif
], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); ppllibs= ; pplinc= ; with_ppl=no ])
@@ -1637,7 +1636,12 @@ if test "x$with_cloog" != "xno" -a "${ENABLE_CLOOG_CHECK}" = "yes"; then
#if CLOOG_VERSION_MAJOR != 0 || CLOOG_VERSION_MINOR != 15 || CLOOG_VERSION_REVISION < 5
choke me
#endif
- ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); clooglibs= ; clooginc= ])
+ ], [AC_TRY_COMPILE([#include "cloog/cloog.h"],[
+ #if CLOOG_VERSION_MAJOR != 0 || CLOOG_VERSION_MINOR != 15 || CLOOG_VERSION_REVISION < 9
+ choke me
+ #endif
+ ], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([buggy but acceptable])])],
+ [AC_MSG_RESULT([no]); clooglibs= ; clooginc= ])
CFLAGS="$saved_CFLAGS"
fi
@@ -1741,7 +1745,6 @@ ACX_ELF_TARGET_IFELSE([if test x"$enable_lto" = x"yes" ; then
elf_nextscn (0, 0);
elf_strptr (0, 0, 0);
elf_getident (0, 0);
- elf_getshdrstrndx (0, 0);
elf_begin (0, 0, 0);
elf_ndxscn (0);
elf_end (0);
@@ -1750,6 +1753,27 @@ ACX_ELF_TARGET_IFELSE([if test x"$enable_lto" = x"yes" ; then
[AC_MSG_RESULT([no]); enable_lto=no; libelflibs= ; libelfinc= ]
)
+ # Check for elf_getshdrstrndx or elf_getshstrndx. The latter's flavor
+ # is determined in gcc/configure.ac.
+ if test x"$enable_lto" = x"yes" ; then
+ AC_MSG_CHECKING([for elf_getshdrstrndx])
+ AC_TRY_LINK(
+ [#include <libelf.h>],[
+ elf_getshdrstrndx (0, 0);
+ ],
+ [AC_MSG_RESULT([yes]);],
+ [AC_MSG_RESULT([no]);
+ AC_MSG_CHECKING([for elf_getshstrndx])
+ AC_TRY_LINK(
+ [#include <libelf.h>],[
+ elf_getshstrndx (0, 0);
+ ],
+ [AC_MSG_RESULT([yes]);],
+ [AC_MSG_RESULT([no]); enable_lto=no; libelflibs= ; libelfinc= ]
+ )]
+ )
+ fi
+
# If we couldn't enable LTO and the user forced it, emit an error.
if test x"$enable_lto" = x"no" \
&& test x"$default_enable_lto" != x"yes" ; then
@@ -2723,7 +2747,7 @@ else
mv conftest.o conftest.o.g0 &&
${CC} -c -g conftest.c &&
mv conftest.o conftest.o.g &&
- ${srcdir}/contrib/compare-debug conftest.o.g0 conftest.o.g; then
+ ${srcdir}/contrib/compare-debug conftest.o.g0 conftest.o.g > /dev/null 2>&1; then
:
else
BUILD_CONFIG=