summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2012-12-12 13:52:55 +0000
committerH.J. Lu <hjl.tools@gmail.com>2012-12-12 13:52:55 +0000
commitc24c2888111acb6905101622fec41f713cd3e275 (patch)
tree6d06af98704cd43dfa7cc511a7330f362dd416ef /configure.ac
parentd4147686a1cba312ef61d42d274beb6f74026fd2 (diff)
downloadgdb-c24c2888111acb6905101622fec41f713cd3e275.tar.gz
Add --with-build-config=bootstrap-asan support
* Makefile.def (target_modules): Add bootstrap=true and raw_cxx=true to libsanitizer. * configure.ac (bootstrap_target_libs): Add libsanitizer. * Makefile.in: Regenerated. * configure: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49f4f5dae88..a92ff3af8b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2433,6 +2433,11 @@ if echo " ${target_configdirs} " | grep " libgomp " > /dev/null 2>&1 ; then
bootstrap_target_libs=${bootstrap_target_libs}target-libgomp,
fi
+# If we are building libsanitizer, bootstrap it.
+if echo " ${target_configdirs} " | grep " libsanitizer " > /dev/null 2>&1 ; then
+ bootstrap_target_libs=${bootstrap_target_libs}target-libsanitizer,
+fi
+
# Determine whether gdb needs tk/tcl or not.
# Use 'maybe' since enable_gdbtk might be true even if tk isn't available
# and in that case we want gdb to be built without tk. Ugh!