summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Stump <mrs@apple.com>2013-07-10 20:55:59 +0000
committerMike Stump <mrs@apple.com>2013-07-10 20:55:59 +0000
commitdf98275232bd6266aea2bddbb4db249ec3f4afeb (patch)
tree75abe4cc88e8135083a50803b0d6eaede5dca4dd /configure.ac
parent50d4284e06d3e48508856a6f56028cfdcadd6166 (diff)
downloadgdb-df98275232bd6266aea2bddbb4db249ec3f4afeb.tar.gz
2013-07-10 Jack Howarth <howarth@bromo.med.uc.edu>
PR target/57792 * configure.ac: Use --with-sysroot=\"`xcrun --show-sdk-path`\" on darwin13 and later. * configure: Regenerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 226239b77d0..d4dc10bd725 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2854,6 +2854,13 @@ if test x${is_cross_compiler} = xyes ; then
target_configargs="--with-cross-host=${host_noncanonical} ${target_configargs}"
fi
+# Pass --with-sysroot on darwin without SDK in /
+case "${target}" in
+ x86_64-*-darwin1[[3-9]]*)
+ host_configargs="--with-sysroot=\"`xcrun --show-sdk-path`\" ${host_configargs}"
+ ;;
+esac
+
# Default to --enable-multilib.
if test x${enable_multilib} = x ; then
target_configargs="--enable-multilib ${target_configargs}"