summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <jsm@polyomino.org.uk>2011-04-01 13:44:53 +0000
committerJoseph Myers <jsm@polyomino.org.uk>2011-04-01 13:44:53 +0000
commite127a5a3d793c289742e9ab5c53fbef1119b7eee (patch)
treed7526b7fc8846a01a5165627adcb4e9c9f592848 /configure.ac
parentf630103a91d4fb3aad4e1b2aca6dae4dded1b8ba (diff)
downloadgdb-e127a5a3d793c289742e9ab5c53fbef1119b7eee.tar.gz
* configure.ac: Remove code setting CONFIG_SHELL, config_shell and
moveifchange. * configure: Regenerate. * Makefile.tpl: Use @SHELL@ not @config_shell@. * Makefile.in: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 0 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index 32df4932cb4..2564ce5ad34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,42 +89,6 @@ AC_PROG_LN_S
AC_PROG_SED
AC_PROG_AWK
-### we might need to use some other shell than /bin/sh for running subshells
-### If we are on Windows, search for the shell. This will permit people
-### to not have /bin/sh, but to be able to see /SOME/PATH/sh configure
-### without also having to set CONFIG_SHELL. This code will work when
-### using bash, which sets OSTYPE.
-case "${OSTYPE}" in
-*win32*)
- if test x${CONFIG_SHELL} = x ; then
- if test ! -f /bin/sh ; then
- if test x${SHELL} != x && test -f ${SHELL} ; then
- CONFIG_SHELL=${SHELL}
- export CONFIG_SHELL
- else
- for prog in sh sh.exe bash bash.exe; do
- IFS="${IFS= }"; save_ifs="$IFS"; IFS="${IFS}:"
- for dir in $PATH; do
- test -z "$dir" && dir=.
- if test -f $dir/$prog; then
- CONFIG_SHELL=$dir/$prog
- export CONFIG_SHELL
- break
- fi
- done
- IFS="$save_ifs"
- test -n "${CONFIG_SHELL}" && break
- done
- fi
- fi
- fi
- ;;
-esac
-
-config_shell=${CONFIG_SHELL-/bin/sh}
-
-moveifchange=${srcdir}/move-if-change
-
srcpwd=`cd ${srcdir} ; ${PWDCMD-pwd}`
# We pass INSTALL explicitly to sub-makes. Make sure that it is not
@@ -2985,7 +2949,6 @@ AC_SUBST(NM_FOR_BUILD)
AC_SUBST(RANLIB_FOR_BUILD)
AC_SUBST(WINDMC_FOR_BUILD)
AC_SUBST(WINDRES_FOR_BUILD)
-AC_SUBST(config_shell)
# Generate default definitions for YACC, M4, LEX and other programs that run
# on the build machine. These are used if the Makefile can't locate these