summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2003-02-19 23:51:03 +0000
committerAlexandre Oliva <aoliva@redhat.com>2003-02-19 23:51:03 +0000
commitcd55b6c3e525687a1dd577c624643a672f149108 (patch)
tree71aa096633631c5d65ec4b91b1833bb2d3eaf93e /configure.in
parente5590954fe8b3c6bbccfed7cc53c7adbd5d61c5b (diff)
downloadgdb-cd55b6c3e525687a1dd577c624643a672f149108.tar.gz
* configure.in: Introduce --enable-maintainer-mode.
* configure: Rebuilt. * Makefile.tpl (Makefile.in, configure): Enable dependencies only for maintainer mode. * Makefile.in: Rebuilt.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6412e7ba040..bb575724ebd 100644
--- a/configure.in
+++ b/configure.in
@@ -2127,4 +2127,23 @@ AR_FOR_TARGET=${AR_FOR_TARGET}${extra_arflags_for_target}
RANLIB_FOR_TARGET=${RANLIB_FOR_TARGET}${extra_ranlibflags_for_target}
NM_FOR_TARGET=${NM_FOR_TARGET}${extra_nmflags_for_target}
+AC_MSG_CHECKING([whether to enable maintainer-specific portions of Makefiles])
+AC_ARG_ENABLE(maintainer-mode,
+[ --enable-maintainer-mode enable make rules and dependencies not useful
+ (and sometimes confusing) to the casual installer],
+ USE_MAINTAINER_MODE=$enableval,
+ USE_MAINTAINER_MODE=no)
+AC_MSG_RESULT($USE_MAINTAINER_MODE)
+AC_SUBST(MAINTAINER_MODE_TRUE)
+AC_SUBST(MAINTAINER_MODE_FALSE)
+if test "$USE_MAINTAINER_MODE" = yes; then
+ MAINTAINER_MODE_TRUE=
+ MAINTAINER_MODE_FALSE='#'
+else
+ MAINTAINER_MODE_TRUE='#'
+ MAINTAINER_MODE_FALSE=
+fi
+MAINT=$MAINTAINER_MODE_TRUE
+AC_SUBST(MAINT)dnl
+
AC_OUTPUT(Makefile)