summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorJoel Brobecker <brobecker@gnat.com>2012-07-25 18:27:03 +0000
committerJoel Brobecker <brobecker@gnat.com>2012-07-25 18:27:03 +0000
commit09a215f4c6aabd8a86402f15e7abd8bc37933993 (patch)
treefd9f95ffe60e9e8ee22c3ffb4adf78dd3ec79caa /gdb/configure.ac
parent47bbf2c7f8fb4d2ef8e46ce1ae6f02c15736b1e6 (diff)
downloadgdb-09a215f4c6aabd8a86402f15e7abd8bc37933993.tar.gz
Add support for --enable-lmcheck configure option.
This allows the user to enable this option at configure time if building a release, or to disable it if building a snapshot. gdb/ChangeLog: * configure.ac: Add --enable-lmcheck configure option. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac21
1 files changed, 19 insertions, 2 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index f3d75b16af4..b33de61e22b 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -645,8 +645,25 @@ AC_SUBST(READLINE_DEPS)
AC_SUBST(READLINE_CFLAGS)
AC_SUBST(READLINE_TEXI_INCFLAG)
-dnl -lmcheck provides cheap enough memory mangling for debugging purposes.
-if $development; then
+# Provide a --enable-libmcheck/--disable-libmcheck set of options
+# allowing a user to enable this option even when building releases,
+# or to disable it when building a snapshot.
+AC_ARG_ENABLE(libmcheck,
+ AS_HELP_STRING([--enable-libmcheck],
+ [Try building GDB with -lmcheck if available]),
+ [case "${enableval}" in
+ yes | y) ENABLE_LIBMCHECK="yes" ;;
+ no | n) ENABLE_LIBMCHECK="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-libmcheck) ;;
+ esac])
+
+# Enable -lmcheck by default (it provides cheap-enough memory mangling),
+# but turn it off for releases.
+if test -z "${ENABLE_LIBMCHECK}" && $development; then
+ ENABLE_LIBMCHECK=yes
+fi
+
+if test "$ENABLE_LIBMCHECK" = "yes" ; then
AC_CHECK_LIB(mcheck, main)
fi