summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2008-12-09 17:18:28 +0000
committerTom Tromey <tromey@redhat.com>2008-12-09 17:18:28 +0000
commit0b104d2741b7f42029e74984b7a3ae8ef97cfebb (patch)
treed5f576a0250a45f59559c60fe55c0d006db18c56 /gdb/configure.ac
parentf9fe8e1a40bb54ce88075b918d8be1a1566c6a48 (diff)
downloadgdb-0b104d2741b7f42029e74984b7a3ae8ef97cfebb.tar.gz
* config.in, configure: Rebuild.
* configure.ac: Check for locale.h, setlocale. Call AM_LC_MESSAGES. * acinclude.m4: Include lcmessage.m4.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 8725aa6e12f..4e0cf7deeba 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -696,7 +696,7 @@ AC_CHECK_HEADERS([nlist.h machine/reg.h poll.h sys/poll.h proc_service.h \
sys/resource.h sys/procfs.h sys/ptrace.h ptrace.h \
sys/reg.h sys/debugreg.h sys/select.h sys/syscall.h \
sys/types.h sys/wait.h wait.h termios.h termio.h \
- sgtty.h unistd.h elf_hp.h ctype.h time.h])
+ sgtty.h unistd.h elf_hp.h ctype.h time.h locale.h])
AC_CHECK_HEADERS(link.h, [], [],
[#if HAVE_SYS_TYPES_H
# include <sys/types.h>
@@ -740,6 +740,7 @@ AC_CHECK_HEADERS(term.h, [], [],
AC_CHECK_DECLS([free, malloc, realloc, strerror, strstr, getopt,
snprintf, vsnprintf])
+AM_LC_MESSAGES
# ----------------------- #
# Checks for structures. #
@@ -775,7 +776,7 @@ AC_FUNC_VFORK
AC_CHECK_FUNCS([canonicalize_file_name realpath getrusage getuid \
getgid poll pread64 sbrk setpgid setpgrp setsid \
sigaction sigprocmask sigsetmask socketpair syscall \
- ttrace wborder])
+ ttrace wborder setlocale])
# Check the return and argument types of ptrace. No canned test for
# this, so roll our own.