summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2013-07-01 19:50:10 +0000
committerTom Tromey <tromey@redhat.com>2013-07-01 19:50:10 +0000
commit132367bed08c96d95cb941601470e708a8469ab9 (patch)
tree1e71633d247ef72017000dd385e1afc0ac667623 /gdb/configure.ac
parente415e0e203cecb5e99ac0218829d301bacfe95f2 (diff)
downloadgdb-132367bed08c96d95cb941601470e708a8469ab9.tar.gz
add -Wold-style-declaration
This adds -Wold-style-declaration to gdb's list of warnings. It turns out that a few places use "const static" rather than "static const". The former is deprecated according to the C standard. Tested by rebuilding with --enable-targets=all on x86-64 Fedora 18. * configure.ac (build_warnings): Add -Wold-style-declaration. * configure: Rebuild. * dsrec.c (make_srec): Use "static const", not "const static". * h8300-tdep.c (h8300_breakpoint_from_pc): Use "static const", not "const static". * mi/mi-parse.c (mi_no_values, mi_simple_values, mi_all_values): Use "static const", not "const static". * mn10300-tdep.c (mn10300_breakpoint_from_pc): Use "static const", not "const static". * moxie-tdep.c (moxie_breakpoint_from_pc): Use "static const", not "const static". * rs6000-tdep.c (rs6000_breakpoint_from_pc): Use "static const", not "const static". * v850-tdep.c (v850_breakpoint_from_pc): Use "static const", not "const static". (v850_dbtrap_breakpoint_from_pc): Likewise. * xstormy16-tdep.c (xstormy16_breakpoint_from_pc): Use "static const", not "const static".
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index b63faec587b..e0e5dd4efde 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1940,7 +1940,8 @@ build_warnings="-Wall -Wdeclaration-after-statement -Wpointer-arith \
-Wpointer-sign \
-Wno-unused -Wunused-value -Wunused-function \
-Wno-switch -Wno-char-subscripts -Wmissing-prototypes \
--Wdeclaration-after-statement -Wempty-body -Wmissing-parameter-type"
+-Wdeclaration-after-statement -Wempty-body -Wmissing-parameter-type \
+-Wold-style-declaration"
# Enable -Wno-format by default when using gcc on mingw since many
# GCC versions complain about %I64.