summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2013-01-09 17:21:28 +0000
committerTom Tromey <tromey@redhat.com>2013-01-09 17:21:28 +0000
commit2e910fbe101d79883344e166925c0a11644e434a (patch)
tree793b4581ec11eb3e05ae48b25de6c95f35d46994 /gdb/configure.ac
parent133bd58147d8d50ab526878ed35898b45063e20a (diff)
downloadgdb-2e910fbe101d79883344e166925c0a11644e434a.tar.gz
* config/pa/hpux.mh (NATDEPFILES): Remove somread.o.
* configure: Rebuild. * configure.ac: Add somread.o to the build if BFD has SOM support. * somread.c: Include som/aout.h, not syms.h. (som_symtab_read): Use som_external_symbol_dictionary_record. Unpack records manually. (_initialize_somread): Declare.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index de096b8d2a7..e501766034f 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -2034,6 +2034,13 @@ if test $gdb_cv_var_macho = yes; then
CONFIG_OBS="$CONFIG_OBS machoread.o"
fi
+# Add SOM support to GDB, but only if BFD includes it.
+GDB_AC_CHECK_BFD([for SOM support in BFD], gdb_cv_var_som,
+ [bfd_som_attach_aux_hdr (NULL, 0, NULL)], som.h)
+if test $gdb_cv_var_som = yes; then
+ CONFIG_OBS="$CONFIG_OBS somread.o"
+fi
+
# Add any host-specific objects to GDB.
CONFIG_OBS="${CONFIG_OBS} ${gdb_host_obs}"