summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorJan Kratochvil <jan.kratochvil@redhat.com>2012-12-09 18:39:57 +0000
committerJan Kratochvil <jan.kratochvil@redhat.com>2012-12-09 18:39:57 +0000
commit94627ec78b502d0a11e15cca47d6173f0e6dff0c (patch)
tree3338c68b971ce97cef1588ea2b47a94b24774e40 /gdb/configure.ac
parent1eb942b49cd19f4bec0cc0737a70c0e65feee60b (diff)
downloadgdb-94627ec78b502d0a11e15cca47d6173f0e6dff0c.tar.gz
gdb/
* configure.ac (CC_HAS_LONG_LONG): Replace by AC_MSG_ERROR. * defs.h (LONGEST, ULONGEST): Remove conditionalization for CC_HAS_LONG_LONG. * dwarf2-frame.c (DW64_CIE_ID): Likewise. * dwarf2read.c (extract_cu_value): Remove the function. (create_cus_from_index_list): Make the return type void, inline the extract_cu_value caller, include new gdb_static_assert. (create_cus_from_index): Make the return type void, update the function comment, update the create_cus_from_index_list caller. (create_signatured_type_table_from_index): Make the return type void, inline the extract_cu_value caller, include new gdb_static_assert. (dwarf2_read_index): Update the create_cus_from_index and create_signatured_type_table_from_index caller. * printcmd.c (ui_printf): Remove conditionalizations for CC_HAS_LONG_LONG. * config.in: Regenerate. * configure: Regenerate. gdb/doc/ * gdbint.texinfo (Host Definition): Remove CC_HAS_LONG_LONG.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 2bfbe73e331..db528040d6b 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1556,9 +1556,9 @@ AC_CACHE_CHECK([for long long support in compiler], gdb_cv_c_long_long,
[[switch (foo & 2) { case 0: return 1; }]])],
gdb_cv_c_long_long=yes,
gdb_cv_c_long_long=no)])
-if test $gdb_cv_c_long_long = yes; then
- AC_DEFINE(CC_HAS_LONG_LONG, 1,
- [Define to 1 if the compiler supports long long.])
+if test $gdb_cv_c_long_long != yes; then
+ # libdecnumber requires long long.
+ AC_MSG_ERROR([Compiler must support long long for GDB.])
fi
# Check if the compiler and runtime support printing long longs.