summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2013-01-02 14:58:13 +0000
committerTom Tromey <tromey@redhat.com>2013-01-02 14:58:13 +0000
commit973437bd6c340c3585dc436bb4eba2bfef13ffde (patch)
tree38388d42203b10187910b86f2ad2abb667b54b81 /gdb/configure.ac
parentfebcf9e50475b5418674f6a4c99fecdae9eaa974 (diff)
downloadgdb-973437bd6c340c3585dc436bb4eba2bfef13ffde.tar.gz
* config/i386/darwin.mh (NATDEPFILES): Remove machoread.o.
* configure.ac: Check for Mach-O support in BFD. Update CONFIG_OBS. * configure: Rebuild.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index a27bc9280dd..de096b8d2a7 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -2027,6 +2027,13 @@ if test $gdb_cv_var_elf = yes; then
fi
fi
+# Add macho support to GDB, but only if BFD includes it.
+GDB_AC_CHECK_BFD([for Mach-O support in BFD], gdb_cv_var_macho,
+ [bfd_mach_o_lookup_command (NULL, 0, NULL)], mach-o.h)
+if test $gdb_cv_var_macho = yes; then
+ CONFIG_OBS="$CONFIG_OBS machoread.o"
+fi
+
# Add any host-specific objects to GDB.
CONFIG_OBS="${CONFIG_OBS} ${gdb_host_obs}"