summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorJoel Brobecker <brobecker@gnat.com>2011-02-02 04:36:15 +0000
committerJoel Brobecker <brobecker@gnat.com>2011-02-02 04:36:15 +0000
commitc08dcfa2035a1313df3cc865a6d8f6e7cbd8c7ac (patch)
tree6ae26a2929fd53bc43739eeaceac7da0e4219786 /gdb/configure.ac
parent443c1710b16276c92ca17efd65b8d9b2a553f362 (diff)
downloadgdb-c08dcfa2035a1313df3cc865a6d8f6e7cbd8c7ac.tar.gz
fix gdb+python build failure if using non-GNU sed
Non-GNU sed do not like the '?' quantifier when used in a s/// regexp that involve back-references, causing the build to fail when trying to link with Python support. This fixes it by using the '*' quantifier instead. gdb/ChangeLog: * configure.ac: Work around non-GNU sed limitation when computing python version number. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 68b083865f8..d2b75f63752 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -769,8 +769,23 @@ else
have_libpython=no
if test "${have_python_config}" = yes; then
+ # Determine the Python version by extracting "-lpython<version>"
+ # part of the python_libs. <version> is usually X.Y with X and Y
+ # being decimal numbers, but can also be XY (seen on Windows).
+ #
+ # The extraction is performed using sed with a regular expression.
+ # Initially, the regexp used was using the '?' quantifier to make
+ # the dot in the version number optional. Unfortunately, this
+ # does not work with non-GNU versions of sed because, because of
+ # what looks like a limitation (the '?' quantifier does not work
+ # with back-references). We work around this limitation by using
+ # the '*' quantifier instead. It means that, in theory, we might
+ # match unexpected version strings such as "-lpython2..7", but
+ # this seems unlikely in practice. And even if that happens,
+ # an error will be triggered later on, when checking that version
+ # number.
python_version=`echo " ${python_libs} " \
- | sed -e 's,^.* -l\(python[[0-9]]*[[.]]\?[[0-9]]*\).*$,\1,'`
+ | sed -e 's,^.* -l\(python[[0-9]]*[[.]]*[[0-9]]*\).*$,\1,'`
case "${python_version}" in
python*)
AC_TRY_LIBPYTHON(${python_version}, have_libpython,