summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorJoel Brobecker <brobecker@gnat.com>2012-10-15 17:17:46 +0000
committerJoel Brobecker <brobecker@gnat.com>2012-10-15 17:17:46 +0000
commite010f740f669de4d0adf039f9e586fa93e1e44a3 (patch)
treefcdd667cd7f0916ffb728f0cb26b088d6689d219 /gdb/configure.ac
parentf45e35bd6b08b2fe82fbfad76b316dba5ac22fdb (diff)
downloadgdb-e010f740f669de4d0adf039f9e586fa93e1e44a3.tar.gz
Build with -DMS_WIN64 on amd64-windows if Python enabled...
... and building with GCC. gdb/ChangeLog: * configure.ac: Build with -DMS_WIN64 if building with Python enabled using GCC on amd64-windows. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index c0fd0e13b8d..fc181fd5e36 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -989,11 +989,25 @@ if test "${have_libpython}" != no; then
# unilaterally defined, and that in turn causes _SGIAPI to evaluate
# to false. So, we work around this issue by defining siginfo ourself
# though the command-line.
+ #
+ # On x64 Windows, Python's include headers, and pyconfig.h in
+ # particular, rely on MS_WIN64 macro to detect that it's a 64bit
+ # version of Windows. Unfortunately, MS_WIN64 is only defined if
+ # _MSC_VER, a Microsoft-specific macro, is defined. So, when
+ # building on x64 Windows with GCC, we define MS_WIN64 ourselves.
+ # The issue was reported to the Python community, but still isn't
+ # solved as of 2012-10-02 (http://bugs.python.org/issue4709).
+
case "$gdb_host" in
irix*) if test "${GCC}" = yes; then
CPPFLAGS="$CPPFLAGS -Dsiginfo=__siginfo"
fi
;;
+ mingw64)
+ if test "${GCC}" = yes; then
+ CPPFLAGS="$CPPFLAGS -DMS_WIN64"
+ fi
+ ;;
esac
# Note that "python -m threading" cannot be used to check for