summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorMark Kettenis <kettenis@gnu.org>2003-01-02 22:49:31 +0000
committerMark Kettenis <kettenis@gnu.org>2003-01-02 22:49:31 +0000
commit4f27fa43519fe8502b6d7f962f51087a4ebea2a7 (patch)
treef203ad98ee19ced3b4ec22d47858f89e2bdef12a /gdb/configure.in
parent4796c499b032848c82aeff46ce1034e86b04f95c (diff)
downloadgdb-4f27fa43519fe8502b6d7f962f51087a4ebea2a7.tar.gz
* acconfig.h (DEFAULT_BFD_ARCH, DEFAULT_BFD_VEC): Remove.
* configure.in: Cleanup section that sources GDB and BFD configure subscripts. Remove evil changequotes here. * config.in, configure: Regenerated.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in33
1 files changed, 13 insertions, 20 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 2d913dc3fa3..2130aba4d37 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -76,31 +76,24 @@ if test "${enable_multi_ice}" = "yes"; then
configdirs="${configdirs} multi-ice"
fi
-dnl
-changequote(,)dnl
-
-. ${srcdir}/configure.host
-
-. ${srcdir}/configure.tgt
+. $srcdir/configure.host
-targ=${target} ; . ${srcdir}/../bfd/config.bfd
-
-dnl
-changequote([,])dnl
+. $srcdir/configure.tgt
-dnl use BFD to determine the default architecture and byte order
-dnl (bfd_vec->byteorder provides the latter).
-targ=${target}
-. ${srcdir}/../bfd/config.bfd
+# Fetch the default architecture and default target vector from BFD.
+targ=$target; . $srcdir/../bfd/config.bfd
-dnl We only want the first arch, if there is more than one.
-targ_archs=`echo ${targ_archs} | sed -e 's/ .*//;'`
+# We only want the first architecture, so strip off the others if
+# there is more than one.
+targ_archs=`echo $targ_archs | sed 's/ .*//'`
-if test x"${targ_archs}" != x ; then
- AC_DEFINE_UNQUOTED(DEFAULT_BFD_ARCH, ${targ_archs})
+if test "x$targ_archs" != x; then
+ AC_DEFINE_UNQUOTED(DEFAULT_BFD_ARCH, $targ_archs,
+ [Define to BFD's default architecture. ])
fi
-if test x"${targ_defvec}" != x ; then
- AC_DEFINE_UNQUOTED(DEFAULT_BFD_VEC, ${targ_defvec})
+if test "x$targ_defvec" != x; then
+ AC_DEFINE_UNQUOTED(DEFAULT_BFD_VEC, $targ_defvec,
+ [Define to BFD's default target vector. ])
fi
AC_ARG_PROGRAM