summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorFernando Nasser <fnasser@redhat.com>2000-12-11 22:36:26 +0000
committerFernando Nasser <fnasser@redhat.com>2000-12-11 22:36:26 +0000
commit719907532bfd7b686be251d5f912840065e6bff9 (patch)
treea047c4aa8583bdb0c5e408df064acd83613aad00 /gdb/configure.in
parent8dd43b2b0b4149d2b4915c69dd574273ed97d969 (diff)
downloadgdb-719907532bfd7b686be251d5f912840065e6bff9.tar.gz
2000-12-11 Fernando Nasser <fnasser@redhat.com>
* Makefile.in (CONFIG_LOBS): New macro. Configured to the files that must be added to the gdblib itself. (DEPFILES): Use CONFIG_LOBS, not CONFIG_OBS. (INIT_FILES): Include CONFIG_OBS. (gdb$(EXEEXT)): Depend on CONFIG_OBS and link with it. (kdb): Ditto. * configure.in (CONFIG_LOBS): New variable. Object files that must be added to gdblib for the specific configuration. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index efe04cdf752..4d22c98709b 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -40,6 +40,7 @@ CY_GNU_GETTEXT
dnl List of object files added by configure.
CONFIG_OBS=
+CONFIG_LOBS=
CONFIG_DEPS=
CONFIG_SRCS=
CONFIG_INITS=
@@ -407,7 +408,7 @@ if test ${build} = ${host} -a ${host} = ${target} ; then
if test "$GCC" = "yes" ; then
AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_HPUX_THREAD_SUPPORT)
- CONFIG_OBS="${CONFIG_OBS} hpux-thread.o"
+ CONFIG_LOBS="${CONFIG_LOBS} hpux-thread.o"
CONFIG_SRCS="${CONFIG_SRCS} hpux-thread.c"
else
AC_MSG_RESULT(no (suppressed because you are not using GCC))
@@ -421,7 +422,7 @@ if test ${build} = ${host} -a ${host} = ${target} ; then
if test -f /usr/lib/libthread_db.so.1 ; then
AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_THREAD_DB_LIB)
- CONFIG_OBS="${CONFIG_OBS} sol-thread.o"
+ CONFIG_LOBS="${CONFIG_LOBS} sol-thread.o"
CONFIG_SRCS="${CONFIG_SRCS} sol-thread.c"
AC_CHECK_LIB(dl, dlopen)
if test "$GCC" = "yes" ; then
@@ -560,7 +561,7 @@ no) enable_netrom=no ;;
esac])
if test "${enable_netrom}" = "yes"; then
- CONFIG_OBS="${CONFIG_OBS} remote-nrom.o"
+ CONFIG_LOBS="${CONFIG_LOBS} remote-nrom.o"
CONFIG_SRCS="${CONFIG_SRCS} remote-nrom.c"
fi
@@ -962,6 +963,7 @@ AC_SUBST(IGNORE_SIM_OBS)
AC_SUBST(ENABLE_CFLAGS)
AC_SUBST(CONFIG_OBS)
+AC_SUBST(CONFIG_LOBS)
AC_SUBST(CONFIG_DEPS)
AC_SUBST(CONFIG_SRCS)
AC_SUBST(CONFIG_INITS)